Advertisement
If you have a new account but are having problems posting or verifying your account, please email us on hello@boards.ie for help. Thanks :)
Hello all! Please ensure that you are posting a new thread or question in the appropriate forum. The Feedback forum is overwhelmed with questions that are having to be moved elsewhere. If you need help to verify your account contact hello@boards.ie

Sofar ME3000SP

Options
1234579

Comments

  • Registered Users Posts: 6,138 ✭✭✭championc


    When operating the Sofar UNLINKED to a Seplos, the Sofar guestimates it's SOC%, and can wildly drift too.

    The lead acid (which is what Default is) charging and discharging curve is very different to LiFePO4 - and it will break your heart if you try and persist with it :(



  • Registered Users Posts: 1,025 ✭✭✭Mr Q


    I've noticed very quickly the Default setting isn't great. It's currently getting me through the day without using all of the battery capacity.

    Did you start out with this setting and then change to a BMS that could communicate with the ME3000?



  • Moderators, Home & Garden Moderators Posts: 6,094 Mod ✭✭✭✭graememk


    Yes.

    I had all sorts of code running it in passive mode, Preventing recalculation of the soc.. or allowing it to recalculate. Mitigated most of the issues. Now it just works.

    The me3000 calculates the SOC on a straight line function of the empty voltage and full voltage.

    It does this after sitting idle for 1 hour

    All other times it works the SOC by columb counting (counting the Ah in and out of the battery)

    Its not too bad but can drift after a few days. The way i stopped it recalculating was getting to to discharge or charge briefly before the hour was up at a low power.



  • Registered Users Posts: 6,138 ✭✭✭championc


    I initially started with this, with Lead-Acids. Broke my heart. Impossible to get true (or even close) SOC. Thankfully I had gotten the Lead-Acid's for free, then sold them for pretty well enough to buy a full set of CALB's.

    But was still an absolute PITA. The Seplos was a game changer.

    And everyone with a Sofar should build a sofar2mqtt, even to just get live stats.



  • Registered Users Posts: 3,398 ✭✭✭randombar


    Don't suppose you want to build on for me 😁

    Tried and failed to build one. Shaky hands and soldering don't go well together.



  • Advertisement
  • Moderators, Sports Moderators Posts: 19,029 Mod ✭✭✭✭slave1


    Thank be to jazuz I entered the battery world post lead-acid, their DOD and high maintenance is something I’d not be cut out for

    My stuff for sale on Adverts inc. EDDI, hot water cylinder, roof rails...

    Public Profile active ads for slave1 (adverts.ie)



  • Moderators, Home & Garden Moderators Posts: 6,094 Mod ✭✭✭✭graememk


    What bits have you?

    I have a handful of rs485 boards but running a bit short on esp8266's.

    I've made 5 so far I think.



  • Registered Users Posts: 3,398 ✭✭✭randombar


    I've one handy all right.

    Also have one I made earlier that doesn't work :D

    Whereabouts are you based?



  • Moderators, Home & Garden Moderators Posts: 6,094 Mod ✭✭✭✭graememk




  • Registered Users Posts: 238 ✭✭insular1


    Hi all, finally getting going with plans to expand my system. Main want was a DIY battery but just discovered we are now eligible for SEAI grant for panels which we weren't before so going to get another 4kwp panels installed. Also been following the DIY battery threads and am planning a 30kWh DIY build as we are pretty heavy electricity users. Since I will have the electrician coming to do the panels my main question is what invertor to go for so I can install battery afterwards. He will have to upgrade the existing invertor anyway so options are:

    1. Upgrade to 6kW hybrid inverter.
    2. Upgrade to 6kW normal invertor and have him also install ME3000SP at the same time.

    What are peoples opinions of the above two options? Which would ye go for? I don't have prices yet but assuming option 1 will be slightly cheaper but are there benefits to the Sofar that would make it more worthwhile?



  • Advertisement
  • Registered Users Posts: 6,138 ✭✭✭championc


    Three benefits of an ME3000

    1. Can be installed in a totally separate location to the string inverter

    2. You could be generating 5kWh AND pull 3kWh from the batteries via the ME3000, meaning you can charge the cars at the full 7kW rate.

    3. You have more flexibility with an ME3000 - you can decide when to charge the batteries or when to charge the cars ahead of the batteries



  • Registered Users Posts: 238 ✭✭insular1


    Are there any options that can pull more than 3kWh from the batteries alone? We have a heat pump which can draw 4 or 5kWh. Be a shame to have a full battery and still be drawing some from the grid in summer.



  • Moderators, Home & Garden Moderators Posts: 6,094 Mod ✭✭✭✭graememk


    The sofar hybrid can do a steady,5kw I think,

    The sunsynk can do it too

    The solis de rates after 15mins to 70amps (from 100)



  • Registered Users Posts: 238 ✭✭insular1


    Thanks a million. I'll look into those.



  • Registered Users Posts: 301 ✭✭spose


    Now that I can see actual ESB data it looks that for most of the day while my sofar says I am importing nothing and just running on battery I actually have a continuous draw of about 60-80W from the grid. Any recommendations on what to do here. Is there a calibrate setting for the ct to add an offset of 60w. I don’t have a clamp on ammeter to check it myself



  • Registered Users Posts: 6,138 ✭✭✭championc


    I had the very same issue. I verified it from the grid graph in the MyEnergi app. By setting -60 in the CT Calibration Menu, I have a constant about 20w. I'm really pushing towards importing Zero day units this month. I'll certainly be disappointed if it's more than 5



  • Registered Users Posts: 301 ✭✭spose


    Cheers. Have been at about 2kwh a day so be interesting to see how much better it gets



  • Registered Users Posts: 6,138 ✭✭✭championc


    Very annoying when you know that you've used zero day units in the month only to end up with the meter saying differently



  • Registered Users Posts: 2,061 ✭✭✭Jnealon


    Has anyone gone down the warranty route with Sofar and how did they get on.

    Mine just died, screen is blank and there is no sign of life. I disconnected everything and powered it back up on the AC side with no luck.

    I've sent off a warranty claim so we'll see how that goes



  • Moderators, Sports Moderators Posts: 19,029 Mod ✭✭✭✭slave1


    Did you contact supplier first?

    My stuff for sale on Adverts inc. EDDI, hot water cylinder, roof rails...

    Public Profile active ads for slave1 (adverts.ie)



  • Advertisement
  • Registered Users Posts: 3,398 ✭✭✭randombar


    I know one of the lads got another shipped to him so hopefully you should be good.

    Managed to do something to the Seplos so need to hard wire the batteries in 16Sp1

    Anyone have the settings to hand for the default battery?



  • Registered Users Posts: 301 ✭✭spose


    Found them very good. Went through some troubleshooting and when couldn’t resolve said because they have no on site technical support in Ireland they’d replace it. Brand new to the door in a few days



  • Registered Users Posts: 6,138 ✭✭✭championc




  • Registered Users Posts: 6,138 ✭✭✭championc


    You may need to snip one of the four wires in the Seplos to ME3000.

    Or if it turns on and then turns off, it's likely the BMS cables are miswired.

    These are the last Default settings I ever used

    Here's my latest settings


    Type Default

    Capacity 185Ah

    Discharge Depth 80% (EPS) 80%

    Max Charge 40A

    Over Protection 58.5v

    Max Charge 58.4v

    Max Discharge 60A

    Low Protection 42.5v

    Min Discharge 49.7v

    Empty Discharged 51.1v

    Fully Charged 53.6v


    But was a bl00dy nightmare



  • Registered Users Posts: 3,398 ✭✭✭randombar


    So tested the Seplos with a tester, the two ports that had cables going into them are dead. Third RS485B is ok.

    So I'll have to hard wire for a while until I get the seplos repaired somehow.

    I think I'll have to take off the ethernet port and replace with another one . .



  • Registered Users Posts: 3,398 ✭✭✭randombar


    Tested all pins. Bottom row are ok, top row are dead.

    Need to see where I can order the socket and get it resoldered, anyone know anyone in Cork? I know a decent guy with a soldering Iron but he's all the way up in Donegal :D



  • Moderators, Home & Garden Moderators Posts: 6,094 Mod ✭✭✭✭graememk


    I've nothing on hand to de solder currently! 😂

    But wait, what is broken/what's going on/how did it break

    On the canbus only pin 4 and 5 is used for the can communication.



  • Registered Users Posts: 3,398 ✭✭✭randombar


    So didn’t get around to putting the nice protective case on the bloody thing.

    young fella amazingly bounced a ball off the cables coming off the board

    network sockets have come off the board slightly from the top, connection is broken from top row of 4 pins

    no communication with the sofar since.



  • Moderators, Home & Garden Moderators Posts: 6,094 Mod ✭✭✭✭graememk


    Yep, that would do it, Even just one of them broken would screw it up.



  • Advertisement
  • Registered Users Posts: 6,138 ✭✭✭championc


    Best way then is to solder wires for an RJ45 socket onto just the points on the PCB of the 3 pins needed



Advertisement