Advertisement
If you have a new account but are having problems posting or verifying your account, please email us on [email protected] for help. Thanks :)
Hello all! Please ensure that you are posting a new thread or question in the appropriate forum. The Feedback forum is overwhelmed with questions that are having to be moved elsewhere. If you need help to verify your account contact [email protected]

Solis disabling backup supply socket

  • 28-09-2022 12:21pm
    #1
    Registered Users Posts: 2,125 ✭✭✭


    So all my network gear went down today and when I checked the attic no lights on anything.

    They are plugged into the backup socket of a Solis 5G hybrid, and have been for months.

    When I checked Advanced settings -> Control parameter -> Backup supply I noticed it was disabled.

    No automation was run on this value or any alarm logged either just decided to disable it.

    I enabled it and 30 mins later the same.

    Thought a short or something but it doesn't trip instantly and I don't have much power coming out of it:

    • 1 x rp4
    • Eir fibre modem/router
    • 2 bay synology NAS
    • surveillance camera system
    • netgear 24 port switch

    Anyone seen this odd and very annoying thing happen?



«1

Comments

  • Registered Users Posts: 1,723 ✭✭✭tnegun


    Any chance there was a firmware update?



  • Registered Users Posts: 2,125 ✭✭✭SD_DRACULA


    Yeah just checked it and still same version.

    Will keep an eye on it



  • Registered Users Posts: 1,723 ✭✭✭tnegun


    Odd one alright I assume that other settings are sticking?



  • Registered Users Posts: 2,125 ✭✭✭SD_DRACULA


    Yeah floating/equalizing charge, batt overvoltage and undervoltage seem to have stayed the same



  • Registered Users Posts: 1,374 ✭✭✭DC999


    I don't have that setup myself or even the knowledge on it. But just thinking through troubleshooting steps..as there is some fault that won't just resolve itself. So Solis disables that backup power supply and unknown why

    If 1) firmware hasn’t changed 2) Solis settings haven't changed 3) and network kit plugged into it hasn’t changed then could be a few things  

    To rule out the network kit, does other non-network gear connected to the power supply? And remove the power block too and put in another, So could plug in a light and fan and leave them on. If it’s anything plugged into it, then it’s back with Solis. If that doesn’t disable it, could you plug stuff in one at a time and see if it’s one of those devices Solis is getting cranky with? As in power the rest of the stuff to the house for now.

    Putting it out there. Could it be down to temp somehow if it’s only setup a few months? Attic is much colder now for 1st time since you set it up. I did once heard of a fault on a server motherboard. Change in temp caused something loose to move ever so slightly. Meant the device went on and off depending on it’s temp. Or devices are doing something else to increase their temp? Seems weird though.

    Could the network kit be drawing more load now somehow and Solis doesn’t like that?

    Could raise a ticket with Solis now so it’s in the queue. Then can add in more detail when you have tested other things. If it's a known issue, they should have a workaround or fix

    Any logs you can get on the Solis to see if it shows a reason?

    Something else?



  • Advertisement
  • Registered Users Posts: 2,125 ✭✭✭SD_DRACULA


    Temp was about 17c so doubt it was that.

    I wish I had the time to troubleshoot this one item at time but not right now.

    I have a socket right next to this one which goes to my CU so if it happens again will swap the devices over.

    However, I think I am also seeing another possible issue: on that same screen it has the charge/discharge set to 70A instead of both being 100A (which I have updated manually but still seems to be 70A)

    So might need to send them an email

    I think someone here had this issue of non-saving values, can't recall the fix.



  • Registered Users Posts: 2,125 ✭✭✭SD_DRACULA


    Yup the limits are also messed up now, stuck at 70a

    Getting tired of this Solis



  • Registered Users Posts: 2,125 ✭✭✭SD_DRACULA


    Happened again.

    Went up saw the alarm light on, no alarms logged because why would it, and then just rebooted itself twice.

    Then I saw in my emails they pushed FW update so that would be why:

    @connesha This is the FW with the 100a - 75a - 100a so I guess I'll let you know how that goes 😂



  • Registered Users Posts: 2,125 ✭✭✭SD_DRACULA


    Surprise surprise FW update did nothing to fix 70a charge/discharge



  • Registered Users Posts: 1,963 ✭✭✭jkforde


    have you tried a full system restart?

    🌦️ 6.7kwp, 45°, SSW, mid-Galway 🌦️



  • Advertisement
  • Registered Users Posts: 2,125 ✭✭✭SD_DRACULA


    It rebooted itself twice during the FW update but haven't powered everything off (inverter/batteries) if that's what you mean

    Weird thing is the BMS values are correct but the inverter ones are forced to 70a.

    Does anyone know the modbus registers to force these values to 100a?




  • Registered Users Posts: 791 ✭✭✭CreadanLady


    is it under warranty? If it is, just get on to the supply telling them it has failed and that you want a replacement.

    I wouldn't bother fluting around with it, if it is doing this something is obviously wrong with it.

    Could be just a unit with some intractible electronic fault inside of it. It's one of these things you could spend for ever investigating and trying to diagnose and fix but possible never get to the end of it.

    Most suppliers wouldn't even bother trying to fix a temperamental piece of kit like this. It would just be into the scrap bin and send a new out a new one. Certainly in commercial settings, companies haven't hours days and weeks on end to be spending fiddling around with a piece of unreliable equipment.

    The MFV Creadan Lady is a mussel dredger from Dunmore East.



  • Moderators, Home & Garden Moderators Posts: 5,515 Mod ✭✭✭✭graememk


    Thats coming from the BMS AFAIK. Do try a full shutdown, batteries included.

    If you set it via modbus, the bms will just set it back.



  • Registered Users Posts: 2,125 ✭✭✭SD_DRACULA


    Looks to me BMS values are correct

    Will try the full shutdown shortly and see how it goes.

    What order is it? Battery first then inverter or the other way around?



  • Registered Users Posts: 89 ✭✭Murt2


    Are you overloading the backup by any chance? Even the largest Solis invertor available can supply 5kW max on the backup supply. What make of battery are you using?



  • Registered Users Posts: 2,125 ✭✭✭SD_DRACULA


    Nah surely not, I was watching it on the display, was way under 200w and not even using the backup supply right now.

    Can't risk that "thing that's supposed to help you shutdown your devices gracefully" do the exact same opposite and break them.



  • Registered Users Posts: 2,125 ✭✭✭SD_DRACULA


    Full shutdown did nothing.




  • Registered Users Posts: 2,125 ✭✭✭SD_DRACULA


    Called them up and they pushed 100a values and they stuck, they don't know why either.

    But they did say it should have worked when I changed them in the screen above and they are NOT the BMS values, they are the inverter ones

    Next time I will try setting them via the registers.



  • Registered Users Posts: 89 ✭✭Murt2


    Who did you call, Solis or Dyness? How did they push it, through Ethernet connection?



  • Registered Users Posts: 2,125 ✭✭✭SD_DRACULA


    Solis since all looked good on the battery side.

    Through the internet via the wifi stick of the inverter.



  • Advertisement
  • Registered Users Posts: 89 ✭✭Murt2



    Strange that it worked for them. Those batteries are only rated at 50Amps continuous, do you have 2 in parallel giving 100Amps?

    What did Solis say about the backup supply? I've mine supplying the whole house, just the heavy loads such as the electric cooker and immersion are on the shared supply, no issues here......Yet....

    Post edited by Murt2 on


  • Registered Users Posts: 2,125 ✭✭✭SD_DRACULA


    4 of them actually so only pulling a measly 25a out of each.

    Quite annoying knowing I can draw 200a continuous but the inverter can't.



  • Registered Users Posts: 89 ✭✭Murt2


    The 5kW models?

    Well that limit is imposed by ESB. No more than 6kW is allowed to be exported, so the inverters don't come with the ability to draw more the 5kW from the batteries. I don't know how that works with Tesla's Powerwall, it's supposed to be able to supply over 10kW, maybe it will just never export that much.....

    Any word on what happened with your backup supply?



  • Registered Users Posts: 2,125 ✭✭✭SD_DRACULA


    The 6kw limit is there yeah but most if not all inverters allow you to set export limit.

    They could for example force a 6kw onto the Irish standard setting and let you use more but having said that I did find an 8kw single phase hybrid inverter for silly money.

    Probably easier to hook up 2 Sofars and that way you can get at least 130A.

    No idea on the backup supply, they couldn't see any logs and it hasn't happened since the FW update.

    Need to start monitoring those charge/discharge values remotely.

    @Jonathan any idea what registers for these 2?




  • Registered Users Posts: 89 ✭✭Murt2


    Exactly, they allow you to set it, so an 8kW inverter could be set by the owner to export 8kW, which ESB don't want, so any bigger than 6kW SP are essentially illegal in Ireland. That's why the manufacturers don't bother with anything over 5kW from battery for this market.

    That backup supply issue is strange. I had a similar issue when there was intermittent strong sunshine. The constant surges from discharge to charge was causing voltage spikes, tripping the battery on overvoltage, which also tripped out the invertor via the BMS. I limited the OV voltage in the invertor settings and it solved the problem, no thanks to my useless, now former, installer. They hadn't a clue what was wrong. The backup supply never defaulted to disabled on mine however.



  • Registered Users Posts: 89 ✭✭Murt2


    Now I'm having the issue of charge and discharge settings being stuck on 70Amps. What's the number you used to contact Solis please? What information do they require to find my inverter?


    Cheers.

    Post edited by Murt2 on


  • Registered Users Posts: 13,770 ✭✭✭✭Ha Long Bay




  • Registered Users Posts: 89 ✭✭Murt2


    Cheers, I sent them an email with the model number and serial number, hopefully that's enough. It must be one of their firmware updates that's caused this.



  • Advertisement
  • Registered Users Posts: 5,300 ✭✭✭con747


    Just checked mine and it's the same. Lets know if you get to the bottom of it.

    Don't expect anything from life, just be grateful to be alive.



Advertisement