Advertisement
If you have a new account but are having problems posting or verifying your account, please email us on [email protected] for help. Thanks :)
Private profiles - please note that profiles marked as private will soon be public. This will facilitate moderation so mods can view users' warning histories. All of your posts across the site will appear on your profile page (including PI, RI). Groups posts will remain private except to users who have access to the same Groups as you. Thread here
Some important site news, please read here. Thanks!

Strava Privacy - adding an address to hide issue

  • 07-11-2021 11:23pm
    #1
    Registered Users Posts: 3,576 ✭✭✭ DeepBlue
    Registered User


    I'm having difficulty adding an address for strava to hide using their "Hide an Address" feature.

    The problem is that strava doesn't recognise the address, and so, can't find it to hide it.

    I'm 95% certain there was a "click the point on a map" option to do this previously and I've 3 addresses already hidden successfully from years ago.

    Is there any way to proceed when strava doesn't recognise the address entered?



Comments

  • Moderators, Sports Moderators Posts: 22,483 Mod ✭✭✭✭ CramCycle
    A wholly unreasonable man


    Seems to have changed, best I can suggest is using an eircode or picking a neighbours address and extending it wide enough



  • Registered Users Posts: 310 ✭✭ strmin
    Registered User


    Use coordinates from https://www.openstreetmap.org/ instead of address. Did the trick for me.



  • Registered Users Posts: 3,576 ✭✭✭ DeepBlue
    Registered User


    It doesn't appear to recognise Irish eircodes. It appears to try to match against US, British, Australian or even Latvian addresses but not Irish.

    Thanks. Is there a particular format to enter the coordinates? I get "No results found" when I enter mine.

    According to strava help it should be possible to use google coordinates:

    Why isn’t my address locating me properly when I edit map visibility?

    This is likely because Google Maps has not correctly indexed your location in its database. Instead, you can enter the latitude/longitude coordinates for your location.

    From the Google Maps website, find the address that corresponds to the location you want to hide.

    Right-click the desired location, and select "What's Here." Upon doing so, the appropriate coordinates will come up in the Maps search bar in the format "37.76447,-122.437529."

    However I still get "No results found" when doing that. 🤔

    It would seem that strava have broken or at least seriously impaired this functionality making it very difficult to add new hidden addresses. I've opened a support request and will post if I get a useful response from that.



  • Registered Users Posts: 8,499 ✭✭✭ Macy0161
    Registered User


    fwiw I've had trouble adding zones (new office/ new parking spots) the last couple of weeks, and my old method using googlemaps coordinates hasn't worked. I've had to use an address and then adjusted the distance.



  • Registered Users Posts: 1,083 ✭✭✭ 2 Wheels Good
    Registered User


    I found the iOS app better for setting privacy zones than the desktop browser. That might be worth trying.



  • Advertisement
  • Registered Users Posts: 3,576 ✭✭✭ DeepBlue
    Registered User


    Good suggestion.

    After dealing with strava support the suggested method that actually worked was the following:

    1. Select your desired location in the google maps mobile app and drop a pin (i.e. long press on the location). The GPS location will appear in the search bar of the google maps app e.g. 52.123456, -9.987654
    2. Copy that GPS location and paste it into the "Add an address" section on the strava app i.e. Settings->Privacy Controls->Map Visibility->Hide the start and end points for activities that happen at a specific address->Add
    3. Set your radius
    4. Voila. Done!


  • Registered Users Posts: 8,499 ✭✭✭ Macy0161
    Registered User


    Just to say, this still wasn't working for me this morning on Chrome, but the above does work in the app. That's the method I've always used on browser as well, so no idea why it works in app but not browser!



Advertisement