Advertisement
If you have a new account but are having problems posting or verifying your account, please email Niamh on [email protected] for help. Thanks :)
New AMA with a US police officer (he's back!). You can ask your questions here

Solax Power app and website

  • 10-02-2021 8:41am
    #1
    Registered Users Posts: 402 ✭✭ drdidlittle


    Anyone else finding reporting issues since upgrade last week?

    Apart from the constant time out issues, last night battery power went from 15% @ 23:58 to 6% @ 00.03. Things like this make you lose all faith that any of the reporting is correct.

    While I like the App interface and usage, the constant time out makes it as useful as t1t5 on a bull.


«1

Comments

  • Registered Users Posts: 3,911 ✭✭✭ mp3guy


    The website has always been a bit shakey, admittedly the refresh is snappier but I guess they're still ironing out some kinks on the back end.

    As far as your battery power, where is the unit stored, what was the internal temperature? Below 5c it goes into a limited mode of operation and may draw power to keep itself above temperature. At 0c it stops functioning altogether.


  • Registered Users Posts: 402 ✭✭ drdidlittle


    Stored in Boiler house and last night wasn't the coldest night we've had. Funny the issue happened over midnight


  • Registered Users Posts: 3,911 ✭✭✭ mp3guy


    You can check the internal battery temperature history in the cloud portal. If it was 5c or lower expect weird behaviour.

    Bear in mind, like most Li-ion batteries, its quoted operational numbers are at ideal temperatures around 25c. It's unlikely your battery has been above even half that for the past couple weeks. So like all batteries, you should expect drastic performance reduction. 20% or possibly even more.


  • Registered Users Posts: 402 ✭✭ drdidlittle


    Hi mp3guy. Never dropped below 15 degrees, was sitting at 18 deg @ midnight. As I said it is in boiler house so getting residual heat from boiler. Another great day here today so I'll monitor again tonight.


  • Registered Users Posts: 3,911 ✭✭✭ mp3guy


    Yeah keep an eye on it. Do you have a screenshot of the power and temp graphs for the battery?


  • Advertisement
  • Registered Users Posts: 402 ✭✭ drdidlittle


    See graphs - looks normal


  • Registered Users Posts: 404 ✭✭ ec_pc


    I can't say I am a fan of recent app update, they seem to have spread the key information across multiple screens where as it was easier to navigate previously. I also get regular timeouts for some reason, only since app update.

    Generally it seems that they develop the user interface in chinese and overlay english so the grammar and spacing is not great at times.

    On Monday, App just would not gather data from the inverter even though it was connected to the internet. I had to reset the entire system to get it back on line. Will be watching this closely.....


  • Registered Users Posts: 227 ✭✭ pale rider


    Dislike the new app and access to it has been hit and miss so far.


  • Registered Users Posts: 402 ✭✭ drdidlittle


    On Monday, App just would not gather data from the inverter even though it was connected to the internet. I had to reset the entire system to get it back on line. Will be watching this closely.....[/quote]

    This happened to me twice in December. At one stage had to cycle the Inverter to get into WiFi log on.


  • Registered Users Posts: 404 ✭✭ ec_pc


    I spent a bit of time looking at this before I restarted the inverter as I really think these should not need to be reset.

    Without getting too much into the IT side of it, In my case, the internet dongle on the inverter is connected to the internet and is responding to ping, so therefore the IP Address etc is ok. But I did notice that the IP address on the inverter itself was not responding.

    I then tried the API to connect to the inverter from my laptop on the same IP subnet and got a response, but data was almost 48 hours out of date. The API relies on the solaxcloud website so I am non the wiser really.

    To me it seems that there was some breakdown in the comms between the inverter and the solaxcloud website which was resolved by the software restarting in the inverter.

    Still getting random timeout issues.....


  • Advertisement
  • Registered Users Posts: 3,911 ✭✭✭ mp3guy


    ec_pc wrote: »
    I spent a bit of time looking at this before I restarted the inverter as I really think these should not need to be reset.

    Without getting too much into the IT side of it, In my case, the internet dongle on the inverter is connected to the internet and is responding to ping, so therefore the IP Address etc is ok. But I did notice that the IP address on the inverter itself was not responding.

    I then tried the API to connect to the inverter from my laptop on the same IP subnet and got a response, but data was almost 48 hours out of date. The API relies on the solaxcloud website so I am non the wiser really.

    To me it seems that there was some breakdown in the comms between the inverter and the solaxcloud website which was resolved by the software restarting in the inverter.

    Still getting random timeout issues.....

    The inverter sends data to the cloud using the MQTT protocol, I intercepted the packets before (they're also unencrypted...). The inverter won't respond to pings, the only open port is the MODBUS over TCP one (which you can also read from locally if you want).

    It's possible that session dies and doesn't get recreated for a while.

    In general the solax servers are just flakey. It seems like they're trying to improve reliability, but I noticed it's particular times of the day they get worse. I suspect perhaps it's when different parts of the world wake up and put increased load on their backend.


  • Registered Users Posts: 287 ✭✭ uphillonly


    New version has been sluggish too for the past few weeks but today it has stopped completely.

    Around 12:00 today iPhone app stopped working saying incorrect username and password. Web page is viewable but showing no data at all. The actual inverter is still showing data which looks correct and recording accumulated kWh and battery percentage.

    Hopefully some refresh happening on their end.


  • Registered Users Posts: 3,911 ✭✭✭ mp3guy


    Honestly their servers are going down pretty much every day, which is why I'm switching to locally monitor the inverters over the ethernet and RS485 ports. Can't be dependent on an internet connection to China to be able to see what the hardware in my shed is doing!


  • Registered Users Posts: 402 ✭✭ drdidlittle


    Android app same way.
    @mp3guy...let us know how you get on with set up. Something I'll look into too when I get the time


  • Registered Users Posts: 402 ✭✭ drdidlittle


    Inverter historical data is missing an hour of data. Not confident it will update correctly


  • Registered Users Posts: 287 ✭✭ uphillonly


    Solax website is back up and running now. Actually seems much quicker than before. Fingers crossed that they have updated the software successfully.

    I'm missing data between 13:00 to 14:00. The total shows as 1.9 kWh for the day in the summary but 6.2 kWh on the actual inverter and on the 'Inverter analysis' tab and the statistic report download. The report, normally set to 5min updates, shows nothing after 12:58 until 14:03 but the kWh does jump from 2.7 at 12:58 to 3.4 at 14:03 so it looks like the inverter is accurate the for day.

    One thing I noticed, my yield does not accumulate all solar generated if the battery is being charged. I only see the amount that has gone to the battery when that is discharged. At the moment this doesn't matter as all surplus is going to the battery and then being used so everything is included by the end of the day. As production increases it will be interesting to see how it records it when I'm trickle charging the car through the zappi. I assume it'll see that as just another appliance.


  • Registered Users Posts: 402 ✭✭ drdidlittle


    One thing I noticed, my yield does not accumulate all solar generated if the battery is being charged. I only see the amount that has gone to the battery when that is discharged. At the moment this doesn't matter as all surplus is going to the battery and then being used so everything is included by the end of the day. As production increases it will be interesting to see how it records it when I'm trickle charging the car through the zappi. I assume it'll see that as just another appliance

    Don't think it ever did. Never see your actual total generation at any point in time, only consumed generation. I pull the statistic data into spread sheet to do calculations. App is only useful for spot data.


  • Registered Users Posts: 3,911 ✭✭✭ mp3guy


    Yeah it's perhaps the worst way of doing it. People want their PV yield for the day, not the "inverted power" yield. This is extra annoying when you charge the battery from the grid, the yield number becomes meaningless, so you have to compute it yourself from the raw PV power stats.


  • Registered Users Posts: 404 ✭✭ ec_pc


    I agree, the service of late has been very poor. My user account is now displaying at not recognised. May indicate some serious problems with their backend systems!

    I am looking at this option :

    https://community.home-assistant.io/t/solax-solar-inverter-setup-guide/48008

    I am using a virtual raspberry PI based option, started to work on this last August but have not really gotten back to it yet.


  • Registered Users Posts: 227 ✭✭ pale rider


    ec_pc wrote: »
    I agree, the service of late has been very poor. My user account is now displaying at not recognised. May indicate some serious problems with their backend systems!

    I am looking at this option :

    https://community.home-assistant.io/t/solax-solar-inverter-setup-guide/48008

    I am using a virtual raspberry PI based option, started to work on this last August but have not really gotten back to it yet.

    Accessing the data is an important feature, getting very fed up of this now, I’m not that technical nor do I feel I should have to be, going to contact my installer and ask them to investigate.


  • Advertisement
  • Registered Users Posts: 3,911 ✭✭✭ mp3guy


    pale rider wrote: »
    Accessing the data is an important feature, getting very fed up of this now, I’m not that technical nor do I feel I should have to be, going to contact my installer and ask them to investigate.

    Unfortunately it's the same way with a lot of inverter manufacturers, software engineering and user experience is a low priority. Even Myenergi have been struggling with QoS lately.

    Your installer will email SolaX, get a nothing answer and that'll be it, you'll just have to wait.


  • Registered Users Posts: 402 ✭✭ drdidlittle


    Got email from UK marketing manager when I emailed Solax.
    Responce was

    Hi drdidlittle

    This will be due to a connection drop in the house between the system and your WiFi router, it is nothing to worry about.

    Head office are aware of the timeout issue and are working on a fix.


    Kind Regards,

    Xxx

    I told him to look into it again as other users had same issue.


  • Registered Users Posts: 402 ✭✭ drdidlittle


    Responce

    Hi drdidlittle

    We’ve had no other complaints of this, if this is the case, please provide me with the usernames or registration numbers of the other customer who have experienced a loss of data at the same time and I’ll have cloud engineers look into it.

    Kind Regards,
    Xxxx

    If anyone else had issues over weekend please PM me for email address. Not sure if I can post it here.


  • Registered Users Posts: 402 ✭✭ drdidlittle


    Another outage today from 12 till 1


  • Registered Users Posts: 287 ✭✭ uphillonly


    Another outage today from 12 till 1

    I've seen the same the last couple of days. The yield totals are correct at the end of the day on the Inverter Analysis tab and on the app though.


  • Registered Users Posts: 404 ✭✭ ec_pc


    I don't want to jinx it, but there is a significant improvement in the app since the outage earlier today.

    No timeouts in Iphone app since plus it seems responsive like it used to be before the upgrades.


  • Registered Users Posts: 402 ✭✭ drdidlittle


    True. Bit of notice on Website or App would solve a lot of frustration about outage


  • Registered Users Posts: 402 ✭✭ drdidlittle


    I see the app has been updated and of late the time outs have gone away. App now opens on the status screen with battery SoC visible. Great improvement in fairness from the previous mess.


  • Registered Users Posts: 287 ✭✭ uphillonly


    Agreed. It seems very stable now, much quicker and improved info.


  • Advertisement
  • Registered Users Posts: 402 ✭✭ drdidlittle


    Has anyone else have the issue of their Solax inverter disconnecting from the WiFi? Mine seems to do it about once a month. Lose all data for the period until you repair. Went offline last night at 04.00.49


Advertisement