Advertisement
If you have a new account but are having problems posting or verifying your account, please email us on [email protected] for help. Thanks :)
Private profiles - please note that profiles marked as private will soon be public. This will facilitate moderation so mods can view users' warning histories. All of your posts across the site will appear on your profile page (including PI, RI). Groups posts will remain private except to users who have access to the same Groups as you. Thread here
Some important site news, please read here. Thanks!

Anti Pollution Faulty Error - 1.6Hdi 09 Citroen Berlingo

  • 26-01-2016 11:28am
    #1
    Registered Users Posts: 1,039 Armaghmagic


    Hi all,

    While driving around xmas, my 2009 Berlingo 1.6HDi cut out a number of times with the engine management light coming on and the 'Anti Pollution faulty' message coming up on the screen. After a while it went off and the van drove perfectly until last Friday when it came back on and the whole 40 mile drive from my gfs house the van was in limp mode, losing power on hills, not going above 2,500rpm and basically driving (and sounding) like a dog.

    First I brought it to a local mechanic who put it on his diagnostic machine and it came back saying Fault with Injector 1. He tried turning off the fault but kept shooting straight back up.

    So I brought it to my mechanic friend who sold me the van and who told me had put 2 new injectors in it 6 months ago. He had them tested and they are all perfect.

    So is there any other way a fault reader could show up an injector issue but the injector itself not be at fault?

    Is there anything else I could have checked?

    Thanks in advance!


Comments

Advertisement