Hi,
I'm posting this to help others avoid the frustration with this nonsense error seen sometimes on WMR headsets.

TLDR:
The Fix:
Go the registry editor, press start and type regedit, press enter to open.
Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\DISPLAY
In there find the default display folder.
Inside that folder, there may be a parameter sub folder.
In the subfolder, see if there is a line that starts with BAD_EDID
If there is, delete the whole parameter folder and reboot.
Now your HMD should be detected as a monitor by windows.

Story:
My Odyssey+ was working perfectly for last few months when on booting my PC up next day, suddenly the mixed reality portal displayed the error 1-4, check your display cable.

I did everything but reinstalling windows. I uninstalled all the usb drivers, the WMR portal itself, nvidia drivers etc.

And still it would not recognise the HMD as a display in device manager.

A windows update was downloaded and applied, upon reboot, my HMD was working again. But after a subsequent reboot by me to check it was still working, it wasn't detected again, same error.

So I knew my connections were ok so it was some configuration problem preventing windows detecting the HMD as a monitor.

The Fix:
Go the registry editor, press start and type regedit, press enter to open.
Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\DISPLAY
In there find the default display folder.
Inside that folder, there may be a parameter sub folder.
In the subfolder, see if there is a line that starts with BAD_EDID
If there is, delete the whole parameter folder and reboot.
Now your HMD should be detected as a monitor by windows.

My PC has survived multiple reboots with this method. If the error shows up again, I will check my registry first before tackling any other troubleshooting methods.