Advertisement
If you have a new account but are having problems posting or verifying your account, please email us on hello@boards.ie for help. Thanks :)
Hello all! Please ensure that you are posting a new thread or question in the appropriate forum. The Feedback forum is overwhelmed with questions that are having to be moved elsewhere. If you need help to verify your account contact hello@boards.ie

6310 and Win2K

Options
  • 01-07-2002 4:16pm
    #1
    Registered Users Posts: 23,212 ✭✭✭✭


    Hi All,

    having a problem with dialling a data connection on a Windows 2000 laptop using a Nokia 6310. Here's what I have so far:

    Tried the 6310 with Win98 via infrared - works fine
    Tried the 6310 with the Win2K laptop - when it goes to dial the number, the phone gives the three tones indicating invalid number (try dialling an invalid number on any phone to hear what I mean).

    Now, here's the fun part. I tried dialling the data number manually - i.e. I dialled it myself using the keypad on the phone. It worked fine, I heard the modem at the other end answering.

    I then fired up hyperterminal on Win2k and connected to the 6310 modem with the AT commands. I dialled the data number with the AT commands and it worked fine!!! On the nokia web site it indicates that placing a semi-colon at the end of the number tells the modem that it is a voice call, no semi-colon and it is a data call.

    What seems to be happening is that my dial up connection is adding a semi-colon to the end of the number and giving an invalid number (hence the three tones). Any ideas how I get rid of it?

    BTW, I have installed the IRCOMM patch for Win2k.

    Thanks,

    TD.


Comments

  • Registered Users Posts: 19,518 ✭✭✭✭Krusty_Clown


    Hi Tom,

    Probably a stoopid question, but you have made sure that your dialup properties are correct, right? i.e. set to tone not pulse, that you've selected your dialling location correctly, that when dialling the number, you are entering the full area code etc..

    I'm sure these are fine.. Just checkin'..
    I have no problem with my 8210 and Win2k.


  • Registered Users Posts: 23,212 ✭✭✭✭Tom Dunne


    Originally posted by Krusty_Clown
    Hi Tom,

    Probably a stoopid question, but you have made sure that your dialup properties are correct, right? i.e. set to tone not pulse, that you've selected your dialling location correctly, that when dialling the number, you are entering the full area code etc..

    I'm sure these are fine.. Just checkin'..
    I have no problem with my 8210 and Win2k.

    Good point, I will double check the settings.

    Though what I did was simply copy the original connectoid (isn't that what they call them these days?) and changed the modem from the internal modem to the 6310 modem. I assume there isn't anything else I have to change? The original worked fine with the landline.

    Thanks Krusty, I will let you know how I get on.

    TD.


  • Registered Users Posts: 19,518 ✭✭✭✭Krusty_Clown


    If the original worked fine with the land-line, don't forget that when dialing using a mobile you have to be specific about which area code you are dialling into (where you dont with land-lines, if dialling into your local area).


  • Registered Users Posts: 23,212 ✭✭✭✭Tom Dunne


    You're gonna love this one...

    The connection didn't work on Esat, switched SIM card to my Vodafone account and it worked without problem!

    This, despite the fact that I could dial the number on Esat using the phone's keypad and got an answer!! Even more bizarre is that I am currently connected at 38Kbps over the damn phone! I thought I could only use HSCD with Vodafone's own 087-6202222 number. I am using it with my work's landline number.

    I don't know...

    Thanks for your help anyway, Krusty.


  • Registered Users Posts: 2,153 ✭✭✭bkehoe


    I think Esat/O2 may have to enable data for your phone. If you dialled the number on the keypad, it would be classed as a voice call. My cousin had to ring anyway, though that MAY have only been to get the 14.4k service enabled....its a few months ago since he mentioned it to me.


  • Advertisement
  • Registered Users Posts: 4,027 ✭✭✭flywheel


    Hi Tom

    If you've set up the 6310 Data Suite software on your laptop you need to alter the modem options before you make calls on the different networks or dial into numbers with different modems

    In the Control Panel the set-up CD installed a Nokia Modem Options and Nokia Connection Manger. You need to alter the settings in the Nokia Modem Options before switching networks.

    The Nokia Modem Options set-up the modem in the 6310 before making the call. Basically it's a GUI to format the INIT strings sent to the modem. Using the wrong INIT string will cause the connection to fail.


    O2 (Esat Digifone):
    bkeogh is right about having it set-up. There is an O2 leaflet called "data - End the speed limit" that discusses 14.4kbps service. It says call 1909 and request 14.4kbps data, get them to send out a leaflet if you can't pop into an O2 store to see if they have one.

    On O2 the maximum you can get is 14.4kbits/s on a Circuit Switched Data (dial-up) call. It's important to use the correct INIT string when connection to O2. The Leaflet tells you to add this INIT string to the Modem Advanced Properties on Win 2K. Go to Control Panel, Modems Icon, Nokia 6310 IrDA, Properties, Advanced. Enter into "Extra Init commands":
    at+cbst=14,0,1

    To be honest, if your using a 6310 and plan to do a lot of data with O2, it would be better to do Data over GPRS.


    Vodafone:
    As you're using Vodafone HSCSD you know that can be pushed up to 43.2kbits/s. It doesn't matter what number you are dialing, only important factor is the modem you are connecting to. You may have to change the Connection method between (Analog) Modem / ISDN V.110 / ISDN V.120 depending on the modem you are dialing.


    HTH,
    Brian G


  • Registered Users Posts: 23,212 ✭✭✭✭Tom Dunne


    Hi Brian,

    thanks for the help. I think I will stick to using my Vodafone SIM with HSCD as the landline number I am dialling is a freephone number. Anyway, I will only be using it intermittently when I go on call as I don't want to be restricted to being somewhere there is a landline for the laptop.

    My O2 mobile is from the job and trying to explain to the account manager that I wan't GPRS to support on-call might be just a little too much for him to grasp, especially in these days of cost cutting. ;)

    Thanks again,

    TD.


Advertisement