Advertisement
If you have a new account but are having problems posting or verifying your account, please email us on hello@boards.ie for help. Thanks :)
Hello all! Please ensure that you are posting a new thread or question in the appropriate forum. The Feedback forum is overwhelmed with questions that are having to be moved elsewhere. If you need help to verify your account contact hello@boards.ie

Toshiba Satellite Pro A300 boot up problem

Options
  • 30-04-2022 9:33pm
    #1
    Registered Users Posts: 140 ✭✭


    Hi all,

    My old Toshiba Satellite Pro A300 running Windows 10 had a problem with updating from 1809 to 1903 version a few years ago. I did not know a solution but found one recently which cured another laptop with the same problem.

    The A300 laptop has been untouched since Feb 2020. Due to Coronavirus travel problems i have only been able to resume the repair using my recently discovered solution.

    Unfortunately, the laptop will not now boot up to Windows. The HDD starts, the laptop lights - power, battery etc come on, the HDD light comes on but quickly goes off, the keyboard caps lock light briefly comes on. The fan continues to run as well as the HDD continues to make usual noises. There is no HDD beeping. The laptop screen remains black, no faint lightening at all. Is there a Screen test I could try to wake up the screen? I let it try to boot up for 15 mons without success.

    HDD is a Hybrid Momentus XT with Windows boot up being on the SSD part as I understand.

    I have put the HDD into a caddy and the 2 parts of the HDD appear under Seagate's SeaTools test program as 2 separate entries.

    A Short Generic Test gives a Pass for both, a Long Generic test gives a Fail for both. I cant remember if I have data on the HDD.

    There was an error message - something on the lines of "Free space was allocated to the MBR" - that error was repaired.

    Any tips, solutions, stuff to try very welcome. I shall be able to try these in the next few weeks.


    Regards all



Comments

  • Moderators, Recreation & Hobbies Moderators, Science, Health & Environment Moderators, Technology & Internet Moderators Posts: 91,074 Mod ✭✭✭✭Capt'n Midnight


    If the drive is more than 7 years old I'd copy everything off it on the basis the original lubricants may have evaporated or gone bad. Replace with an SSD. If cache is faulty then not sure how to bypass it , maybe run ddrescue in reverse multiple times over part of the disk and then do the rest?

    This suggests that the cache is only for read. Windows is not on the SSD. The bits of windows used most are cached there, sorta like readyboost.

    Can you get into the BIOS or do you see Toshiba logo , you should without the disk as otherwise it would suggest a hardware problem



  • Registered Users Posts: 140 ✭✭HPMan


    The screen is black, i think i might had seen the small flashing line in the top left but i am not sure for certain.

    I cannot get into the BIOS screen, i forgotten what F key i need to get there under Windows 10.

    I recently after my testing had finished, found a Screen / Video card test keyboard combo online so i will try that when i can.

    The HDD is over 7 years old but SMART gives no fatal error.

    I havent heard of ddrescue before so i shall have to gem myself up.

    Yes, thinking about it now, the C drive contains Windows but did not have any User folders linked to my own data, from memory i can only recall Public User as opposed to anything personal.

    I didnt know / test for Toshiba logo without the HDD installed so shall try when i can.

    Is it possible to just "put on the latest Windows 10 version" and run the setup from the caddy using basic hardware settings / Microsoft generic drivers and then install into the A300 to download /install Toshiba specific drivers?


    Regards and thanks for all the help



Advertisement