Advertisement
If you have a new account but are having problems posting or verifying your account, please email us on [email protected] for help. Thanks :)
Private profiles - please note that profiles marked as private will soon be public. This will facilitate moderation so mods can view users' warning histories. All of your posts across the site will appear on your profile page (including PI, RI). Groups posts will remain private except to users who have access to the same Groups as you. Thread here
Some important site news, please read here. Thanks!

Lane assist new 3 series

  • 17-07-2021 11:24am
    #1
    Registered Users Posts: 1,085 ✭✭✭ blingrhino


    Mrs Bling got a new 3 series. Diesel shock horror !

    the lane assist would drive you crazy on country roads.

    i have turned it off through the idrive menu but it still intervenes.

    On my A6 one touch of a button and thats it.

    is their any way to solve this?

    Great car otherwise.

    Post edited by biko on


Comments

  • Registered Users Posts: 7,168 ✭✭✭ JoeA3


    It’s mandatory on new cars for it to be enabled / turned on every time you restart the car. Agree it’s very annoying on anything but motorways

    Not 100% sure about BMW’s but there’s probably an easy shortcut to turn it off, e.g. there is a button on the indicator stalk on VAG cars.



  • Registered Users Posts: 50,125 ✭✭✭✭ bazz26


    This video below shows you how to setup an individual setting where you can customise what you want activated or deactivated so that when you get in to the car every time you just select individual mode instead of having to go into the idrive settings everytime:



    Yes I know it's a video of a 7 Series but they all current models use the same idrive operating system version these days.



  • Registered Users Posts: 3,124 ✭✭✭ carsfan2


    I have a new 3 series and turned everything down to minimum in the settings and it has stayed that way whenever I unlock but the setting is linked to the key you use so you would need to do it for both keys to ensure they’re the same assuming you both have your own key.



  • Registered Users Posts: 1,085 ✭✭✭ blingrhino


    I have it off in the idrive.

    But still interferes when driving .

    You had me thinking but I double checked.




  • Registered Users Posts: 726 ✭✭✭ athlone573


    Are you sure it is the "lane assist" causing your symptoms?

    If I remember correctly, BMW 's have a larger "dead spot" in the steering than other cars. Lane Assist on the other hand depends on road markings, which may not exist on "country roads"



  • Advertisement
  • Registered Users Posts: 3,124 ✭✭✭ carsfan2


    I just had a look in Bimmerpost and there is a thread on this.

    https://g20.bimmerpost.com/forums/showthread.php?t=1755297

    Check the last few posts, apparently you need latest software update for it to work which I have.

    If you don't have it bring to dealer for update.



  • Registered Users Posts: 1,085 ✭✭✭ blingrhino


    Thanks carsfan I think it must be a software update thingy.

    It's a 202 so maybe the newer version have the bug fix



  • Registered Users Posts: 3,124 ✭✭✭ carsfan2


    Yes. It’s the March 2021 update that sorts it.

    bring it to the main dealer and they’ll do it.



Advertisement