Advertisement
How to add spoiler tags, edit posts, add images etc. How to - a user's guide to the new version of Boards
Mods please check the Moderators Group for an important update on Mod tools. If you do not have access to the group, please PM Niamh. Thanks!

Pure Telecom Voip

  • #1
    Registered Users Posts: 82 ✭✭✭ techi


    Hi Guys,
    I have my broadband/phone with pure telecom however I use my own modem and voip handsets and have done for a long time.

    I have two services currently running perfectly on my grandstream setup but for the life of me I cant get the pure telecom setup to work, so any pointers or help would be great.

    I have the Grandstream DP750 base with 2 x DP720 handsets all with latest firmware.

    What I have from Pure Telecom is as follows.

    sip username: [email protected] (33 Characters long, I assume drop the + as max username is 32 characters?)

    SIO Password: xxxxxxxxxxxxxx (14 characters long)

    registrar: vobb-pub.voice.puretelecom.ie
    Primary proxy: vobb-pub.voice.puretelecom.ie
    Sip domain: voice.puretelecom.ie
    Ports are both: 5080

    So either im entering the information incorrectly or Pure have given me incorrect password, hopefully someone has experience of the grandstream setup.

    TIA


Comments



  • Latest firmware actually allows the 33 characters but still no joy connecting.




  • techi wrote: »
    Hi Guys,
    I have my broadband/phone with pure telecom however I use my own modem and voip handsets and have done for a long time.

    I have two services currently running perfectly on my grandstream setup but for the life of me I cant get the pure telecom setup to work, so any pointers or help would be great.

    I have the Grandstream DP750 base with 2 x DP720 handsets all with latest firmware.

    What I have from Pure Telecom is as follows.

    sip username: [email protected] (33 Characters long, I assume drop the + as max username is 32 characters?)

    SIO Password: xxxxxxxxxxxxxx (14 characters long)

    registrar: vobb-pub.voice.puretelecom.ie
    Primary proxy: vobb-pub.voice.puretelecom.ie
    Sip domain: voice.puretelecom.ie
    Ports are both: 5080

    So either im entering the information incorrectly or Pure have given me incorrect password, hopefully someone has experience of the grandstream setup.

    TIA

    The SIP Registry server doesn't resolve in public DNS. Double check with Pure Telecom you have the correct settings.




  • Mr. G wrote: »
    The SIP Registry server doesn't resolve in public DNS. Double check with Pure Telecom you have the correct settings.

    @MrG thanks for that I'll follow up and let you know.




  • Hi Guys,
    Well got the reply from pure telecom and they have sent setting to their modem which shows online, as per Mr.G none of these address's will resolve so i'm completely stumped.

    I've taken some screenshots maybe someone can spot something I'm missing.




  • techi wrote: »
    Hi Guys,
    Well got the reply from pure telecom and they have sent setting to their modem which shows online, as per Mr.G none of these address's will resolve so i'm completely stumped.

    I've taken some screenshots maybe someone can spot something I'm missing.

    Can you ask pure telecom for their DNS server details? Perhaps you need to use their DNS server for the addresses to resolve (or substitute the correct IPs after finding them from the Pure Telecom DNS)


  • Advertisement


  • SIP ALG enabled on the modem?

    Try disabling it and see how ya get on.SIP ALG can really **** up SIP traffic




  • I'm using the wrt3200acm with openwrt, don't recall sip alg but i'll check




  • no alg enabled within modem




  • Hi, did you ever get this working? Im trying to get softphone working but hostnames are not resolving.




  • jjbie wrote: »
    Hi, did you ever get this working? Im trying to get softphone working but hostnames are not resolving.

    unfortunately not, it’s appears the password given is encrypted and the hostnames are wrong, I’ve contacted pure T and eir before them, but there’s an unwillingness to divulge correct information.


  • Advertisement


  • I'm a bit late to the party here but I can explain the issues you faced.

    The hostname is correct. It points to a NAPTR record

    Doing a NAPTR lookup on

    vobb-pub.voice.puretelecom.ie

    returns
    vobb-pub.voice.puretelecom.ie. 86400 IN	NAPTR	100 50 "s" "SIP+D2U" "" _sip._udp.vobb-pub.voice.puretelecom.ie.
    vobb-pub.voice.puretelecom.ie. 86400 IN	NAPTR	100 40 "s" "SIP+D2T" "" _sip._tcp.vobb-pub.voice.puretelecom.ie.
    

    which are pointing to SRV records one for UDP and one for TCP

    Doing an SRV lookup on

    _sip._udp.vobb-pub.voice.puretelecom.ie

    gives
    _sip._udp.vobb-pub.voice.puretelecom.ie. 21599 IN SRV 200 0 5080 vobb-pub-cld.voice.puretelecom.ie.
    _sip._udp.vobb-pub.voice.puretelecom.ie. 21599 IN SRV 100 0 5080 vobb-pub-srl.voice.puretelecom.ie.
    

    So

    vobb-pub-srl.voice.puretelecom.ie
    is the preferred server with
    vobb-pub-cld.voice.puretelecom.ie as backup.
    5080 is the port.
    TCP or UDP accepted.

    Some SIP devices have an option for DNS SRV. If so you would enable that setting and use

    vobb-pub.voice.puretelecom.ie

    as the server and the device will append the _sip._udp (by default) and perform the SRV lookup. You get the benefit of server redundancy this way.

    The password given may still be incorrect but that explains the hostname.




  • Thanks for the info will try that,


Advertisement