Advertisement
Boards Golf Society are looking for new members for 2022...read about the society and their planned outings here!
How to add spoiler tags, edit posts, add images etc. How to - a user's guide to the new version of Boards

UPC Horizon Phone might be on SIP...

  • #1
    Registered Users Posts: 851 ✭✭✭ lotas


    So, today, i was looking at my firewall logs for something, when i noticed an interesting connection between my android phone and an IP on UPC... and they where talking on port 5061... I checked the phone and the only "voip" app i have is the horizon voip app...

    So, i noticed that the firewall was blocking this connection, and my phone was saying i was not connected to the UPC phone service... So, i enabled port 5061 out, restarted the app and heay presto! It works!

    now to do some more digging...


Comments



  • That IP address should be the sip server, have you tested to configure the sip software with that IP address and your details for UPC. Can you pass here or on PM the IP address?




  • You might be able to snoop the password using Wireshark or a similar packet sniffer if they don't use encryption.

    Although I suspect it's against their Terms of Service to use a SIP device other than their supplied adapter for the Horizon phone service. I think they offer a SIP trunking service for businesses but whenever I asked nobody seems to know, probably for Government/High end users rather than small/medium sized businesses or home users....




  • nava: I will pm you the IP, but i think it might be somewhat dynamic... I tried connecting using X-Lite, but i cant find the option to change the port, and it keeps trying to connect on 5060, not 5061...

    Mr. G: tried that... its encrypted...




  • right... so a bit more digging... I used the Blink Client[1] to try connect to the IP address. Not going to publicly put the IP up here, but if you want it, you can either use the UPC app on your phone and watch for traffic to 5061, or PM me.... Given you probably need Horizon Phone service enabled, you might as well go down that route, plus we can confirm if there are more than 1 server floating around...

    Anyway, i tried the following usernames as tests (all using my "My UPC" password)

    * username used to log into the my upc site
    * my phone number in 01xxxxxxx format
    * my phone number in +3531xxxxxxx format

    no luck. I did manged to get 401 unauthorized responces back, so at least i am hitting the server.

    For connecting, i created a new account with my sip name being [email protected] address and the password as stated above. That dident work.

    Then, under the server settings tab for the account, i set it to "always use proxy for outgoing sessions", put in the IP, port 5061 and set the transport to TLS... and thats when i started getting 401 errors... mind you, in the last few min, i have started to get back 403 errors: Try again later... i must have hit something i shouldent have... more digging required...

    [1]:http://icanblink.com/




  • and just as a follow up, it seems to be my IP thats being blocked, not the username, since i changed to one of the others and still no dice...

    of note i did find this:

    Server: Sipwise NGCP LB 2.X


  • Advertisement


  • curiousior and curiouser... from their terms and conditions page:[1] Not to use access to the Service to obtain information necessary for customer to design, develop or update unauthorized software that customer uses or provides to others to use to access the Service. The software for this service is using an open source code by Sofia SIP stack (http://sofia-sip.sourceforge.net/ )

    also, this is out of the terms and conditions:

    (d) You shall not access or attempt to access the Service by any means other than through the UPC Phone App environment.

    [1]:http://www.upc.ie/snippets/horizon-phone/termsandconditions/




  • I did a quick test before I left the house with the IP and my UPC login and password but didn't work I was using a grandstream phone, I also tested now with the Softphone app on Iphone over 3G but gets stock on Registering, need to k if there's a log of the attempt of registering.




  • yea, blink allows you to log all sip traffic to a log file. this is what i am using and i can see whats going on... on a side note, i dropped an email to UPC's service department for the phone app saying i noticed it was SIP and asking for the details... fat chance it will work, but worth a shot... any UPC techs out there who would like to tell us whats going on? you can remain nameless!




  • Try using the number in format 35311234567 instead of +35311234567.

    Try using the same login as you would for Wi-Free. I suspect it would be something like your account number as the username and a pregenerated password which is not your regular password (try your default login?).

    So they're using SIP. Kind of guessed that, at least they're using encryption, a lot of Irish ones don't.




  • Mr. G: tried with out the plus, no dice... also tried my WiFree Password and my My UPC password... still no luck...


  • Advertisement


  • also tried my account number as a password, no luck either... thinking of trying to reverse engineer the apk...




  • Has anyone gotten any further on this lately? I too would be interested. I use another softphone client on iOS which is far more accessible to blind screen reader users than Virgin media's Home Phone app.


Advertisement