Advertisement
If you have a new account but are having problems posting or verifying your account, please email us on [email protected] for help. Thanks :)
Hello All, This is just a friendly reminder to read the Forum Charter where you wish to post before posting in it. :)

Thieve's Guild Radiant Quest Problem

  • 25-04-2015 1:33pm
    #1
    Administrators, Business & Finance Moderators, Society & Culture Moderators Posts: 16,815 Admin ✭✭✭✭✭ Toots


    I suppose this isn't a massive problem, I've finished the Thieve's Guild questline, so the radiant quests aren't essential, but I still enjoy doing them. Anyhoo, my problem is this: I was given a shill job by Vex - plant the stolen garnet in the house of Clan Shattershield in Windhelm.

    I did a few other bits before heading to Windhelm, but I duly arrived and proceeded to break into the house and find the chest with the quest marker, but when I opened it and went into my inventory, the stolen garnet wasn't anywhere. I've got barely anything in my inventory, so I'm definitely not skipping over it by mistake.

    I ended up using the console command to complete the quest, however when I go back to Vex, the option to ask for a new job doesn't appear. Neither does the option to quit the shill job. Reloading an earlier save isn't an option, because between being in Windhelm and going back to Vex, I found the remaining 5 Stones of Barenziah (I figured I'd hang on until I found the stones, then head back to the guild and get a new job, plus tell her I found all the stones).

    I tried using console commands to trigger another shill/burglary/sweep/heist job, but nothing is working. I also tried recycleactor on Vex, but all that did was take her clothes off, so I had to go and put them back on.

    Has anyone any ideas of anything else I could try?


Comments

  • Registered Users Posts: 10,595 ✭✭✭✭ degrassinoel


    sounds like you could only have missed the pickup from the questgiver - that even that's really weird as they'd have reached a point in the dialogue where it'd drop into your inventory and once it's there, you cant remove it afaik.. unless...

    Can it be sold after the original quest is done?


  • Administrators, Business & Finance Moderators, Society & Culture Moderators Posts: 16,815 Admin ✭✭✭✭✭ Toots


    I don't think any of those shill bits can be sold. I know any time I've had stuff like that in my inventory and I went to sell stuff, the loot or thing I was supposed to plant didn't even appear as a sellable item.


Advertisement