Advertisement
If you have a new account but are having problems posting or verifying your account, please email us on hello@boards.ie for help. Thanks :)
Hello all! Please ensure that you are posting a new thread or question in the appropriate forum. The Feedback forum is overwhelmed with questions that are having to be moved elsewhere. If you need help to verify your account contact hello@boards.ie

AD - Disabled accounts and OOO

Options
  • 08-05-2009 10:20am
    #1
    Closed Accounts Posts: 4,791 ✭✭✭


    Hi All,

    Question if I disable a users account in AD does the OOO (out of office) still work.

    Is it possible to disable the users login but retain the exchange capabilities etc.


Comments

  • Registered Users Posts: 3,088 ✭✭✭Static M.e.


    Question if I disable a users account in AD does the OOO (out of office) still work.

    Yes, they are not related.. in that way

    Is it possible to disable the users login but retain the exchange capabilities etc.

    Yes, see above. Could depend on what version of Exchange you are running, I wouldnt know the older versions quite as well


  • Registered Users Posts: 8,813 ✭✭✭BaconZombie


    There is no issue with Exchange 2003 or 2007.

    In work if people go on Maternity or sick leave we setup the OoO and then disable the AD account.


  • Closed Accounts Posts: 4,791 ✭✭✭JJJJNR


    I enabled my OOO on my own account and then disabled my AD account , and the OOO didn't work.


  • Registered Users Posts: 327 ✭✭Bebop


    If you disable a users account in AD, they cannot get e-mail, therefore OOO will not work, senders will get a NDR saying the user account does not exist, this applies to any version of Exchange that I have worked with; although OOO is essentially a server side function it depends on a valid account existing in the AD, no account = no mail = exchange will generate a NDR


  • Registered Users Posts: 10,262 ✭✭✭✭Standard Toaster


    As long as the mailbox has not been deleted the out of office should fire away with no problems & the account will still receive the message.
    If user leaves the organization, this can be setup to let their contacts know they are no longer with the company.


  • Advertisement
  • Registered Users Posts: 327 ✭✭Bebop


    I tried this experiment on a live Exchange server today..


    We have 2 Exchange 2003 servers, 1 standard ed & 1 enterprise ed. working on a Server 2003 domain with 300+ mail users
    I set up a test account, logged onto Outlook as this user and enabled OOO
    Sent and received mail on the test account OK
    Disabled the test account leaving the mailbox and OOO in place
    gave exchange time to replicate..then
    tried sending a message to the test account using my GMail address
    Exchange sent me a non delivery report;
    ******************************
    The following recipient(s) could not be reached:

    username 17/06/2009 16:44
    The message reached the recipient's e-mail system, but delivery was refused. Attempt to resend the message. If it still fails, contact your system administrator.
    <mailserver> #5.2.1>
    *********************************
    no OOO was received

    If a disabled account cannot send or receive mail the OOO will not work

    Maybe you guys could try this yourselves and see if you get a different result, it would be interesting to see how my configuration compares with yours


  • Registered Users Posts: 10,262 ✭✭✭✭Standard Toaster


    That's the default settings of exchange. Internally you'd get an ooo response but you need to enable it for external.

    Exchange System Manager - Global Settings -> Internet Message Formats
    Right click "Default". Select Properties _> Advanced.
    Tick the "Allow out of office responses" box. Click apply/ok.

    That's from memory so I may be wrong with the steps above but you'll find it handy enough.


  • Registered Users Posts: 327 ✭✭Bebop


    The_Edge wrote: »
    That's the default settings of exchange. Internally you'd get an ooo response but you need to enable it for external.

    Exchange System Manager - Global Settings -> Internet Message Formats
    Right click "Default". Select Properties _> Advanced.
    Tick the "Allow out of office responses" box. Click apply/ok.

    That's from memory so I may be wrong with the steps above but you'll find it handy enough.

    That box is ticked by default, it is a global setting that toggles the OOO on or off for all users, it does not change the behaviour of a disabled account,
    If you do find out how to do this let me know, I would be interested in trying it out


Advertisement