Advertisement
If you have a new account but are having problems posting or verifying your account, please email us on hello@boards.ie for help. Thanks :)
Hello all! Please ensure that you are posting a new thread or question in the appropriate forum. The Feedback forum is overwhelmed with questions that are having to be moved elsewhere. If you need help to verify your account contact hello@boards.ie

Mac to PC connection

Options
  • 07-04-2009 7:19pm
    #1
    Registered Users Posts: 86 ✭✭


    I'm having trouble with connecting my macbook to my PC. I've got the 2 connected directly via ethernet and when I try to connect my macbook to the PC (In finder Go>Connect to server) it doesn't connect.

    I'm typing "afp://169.254.182.83/SharedDocs" into the window that pops up but when I try to connect, it's spends about a minute trying to connect then says "connection failed."

    Any help you can give me would be greatly appreciated! Thanks!!

    By the way, my macbook is running OSX 10.5.6 and my PC is running XP.

    Thanks again!


Comments

  • Moderators, Music Moderators Posts: 23,361 Mod ✭✭✭✭feylya


    Are you using a crossover cable?


  • Registered Users Posts: 6,762 ✭✭✭WizZard


    If both machines have gigabit ethernet a crossover cable is (usually) unnecessary.

    You'll also need to use SMB.

    AFP is a proprietary protocol and Windows PCs don't support it by default.

    Assuming that sharing is correctly set up in XP you can use smb://169.254.182.83/SharedDocs


  • Registered Users Posts: 86 ✭✭rogers4815


    Thanks for the help but smb://169.254.182.83/SharedDocs doesn't work for me, I'm still getting the same message.

    I know the connection works because I can access the internet on the PC via the Macbook's AirPort...

    Any ideas what I'm doing wrong?


  • Registered Users Posts: 6,762 ✭✭✭WizZard


    Have you turned on File and Printer sharing on your Windows machine?

    Here's a handy guide: http://www.ifelix.co.uk/tech/3020.html


  • Registered Users Posts: 998 ✭✭✭zekiel


    The other thing to check is that you dont have windows firewall or another firewall enabled... its probably blocking access to the pc.


  • Advertisement
  • Registered Users Posts: 3,568 ✭✭✭ethernet


    WizZard wrote: »
    If both machines have gigabit ethernet a crossover cable is (usually) unnecessary.

    You'll also need to use SMB.

    AFP is a proprietary protocol and Windows PCs don't support it by default.


    Assuming that sharing is correctly set up in XP you can use smb://169.254.182.83/SharedDocs
    +1 on using SMB.

    By the way, is that the actual IP address? The 169.x.y.z is usually what you get when the machine gives up trying to get an IP address from the DHCP server. Worth looking into that or you won't get anything working.


  • Registered Users Posts: 6,762 ✭✭✭WizZard


    ethernet wrote: »
    By the way, is that the actual IP address? The 169.x.y.z is usually what you get when the machine gives up trying to get an IP address from the DHCP server. Worth looking into that or you won't get anything working.
    Seems like s/he's using internet connection sharing which will give out an IP address in that space by default.
    That private range (169.254.0.0 -169.254.255.255) is used by Automatic Private IP Addressing.


  • Registered Users Posts: 86 ✭✭rogers4815


    It's working a treat now!!!:D Thanks for all your help!!!


Advertisement