Boards.ie uses cookies. By continuing to browse this site you are agreeing to our use of cookies. Click here to find out more x
Post Reply  
 
Thread Tools Search this Thread
14-10-2012, 15:07   #1
dickwod1
Registered User
 
dickwod1's Avatar
 
Join Date: Feb 2011
Location: Maxwell House
Posts: 1,250
Hotpoint WDL540 washer dryer "door lock" broken flashing lights

Hi my Hotpoint WDL540 washer dryer has a problem,

The door wouldn't unlock after the wash cycle so I removed the bottom panel to pull the cord provided to open the door.

Now when I try to start the washing machine the cycle is on "pause" with the top three lights lit and when I press the "start/pause" button that is flashing the door clicks 6 times and then the bottom light "lock" flashes red.

I have removed the filter and cleaned it, removed the water feed in and cleaned them, unplugged the machine for hours and tried again, stopped and started many times, and its still the same

Any help welcome

Picture of light panel \/
Attached Images
File Type: png hotpoint.PNG (404.9 KB, 72 views)
dickwod1 is offline  
Advertisement
14-10-2012, 18:08   #2
anuprising
Registered User
 
Join Date: Nov 2011
Posts: 367
hi . i cant open the link to your picture but on the wdl 540 , the top 3 lights lit is fault code f07 -washing machine heater relay stuck
anuprising is offline  
14-10-2012, 18:28   #3
dickwod1
Registered User
 
dickwod1's Avatar
 
Join Date: Feb 2011
Location: Maxwell House
Posts: 1,250
Quote:
Originally Posted by anuprising View Post
hi . i cant open the link to your picture but on the wdl 540 , the top 3 lights lit is fault code f07 -washing machine heater relay stuck
Hi thanks but the problem is the bottom light flashes its for the door lock the door clicks 6 times also
dickwod1 is offline  
14-10-2012, 19:37   #4
anuprising
Registered User
 
Join Date: Nov 2011
Posts: 367
[QUOTE=dickwod1;81240248

machine the cycle is on "pause" with the top three lights lit and when I press the "start/pause" button that is flashing the door clicks 6 times and then the bottom light "lock" flashes red

\/[/QUOTE]

top three lights is fault code f07 -washing machine heater relay

the flashing red light indicates either the door lock or the pcb board is faulty

given that the machine is signalling a fault code about the heater relay which is located on the pcb board that would be the first place i would look

diagnostics and fault codes are only an aid to find the problem and this one prob needs someone who knows what they doing

you could try replacing the door lock ,but if its signaling relay that has to be checked also
anuprising is offline  
14-10-2012, 21:05   #5
dickwod1
Registered User
 
dickwod1's Avatar
 
Join Date: Feb 2011
Location: Maxwell House
Posts: 1,250
Quote:
Originally Posted by anuprising View Post
top three lights is fault code f07 -washing machine heater relay

the flashing red light indicates either the door lock or the pcb board is faulty

given that the machine is signalling a fault code about the heater relay which is located on the pcb board that would be the first place i would look

diagnostics and fault codes are only an aid to find the problem and this one prob needs someone who knows what they doing

you could try replacing the door lock ,but if its signaling relay that has to be checked also
Hi thanks for your reply again,

I looked up how to replace the interdoor lock found a video on youtube and took it out , I then plugged back in the washing machine and the 3 top lights are gone but when I press start the lock light still comes on.

So I refitted the lock and plugged it back in and the 3 top lights are off but when I press start the lock clicks 6 times and the "lock" light remains on.

So with your help im guessing its the door lock which is like this http://www.ebay.ie/itm/140515019867?...#ht_1999wt_906

Do you know anywhere in Ireland I could buy one of these?
dickwod1 is offline  
Advertisement
14-10-2012, 21:52   #6
anuprising
Registered User
 
Join Date: Nov 2011
Posts: 367
try charlie shields in inchicore or kenco in glasnevin - google them
anuprising is offline  
14-10-2012, 22:26   #7
dickwod1
Registered User
 
dickwod1's Avatar
 
Join Date: Feb 2011
Location: Maxwell House
Posts: 1,250
Quote:
Originally Posted by anuprising View Post
try charlie shields in inchicore or kenco in glasnevin - google them
Will do, Thanks for all your help
dickwod1 is offline  
15-10-2012, 16:02   #8
dickwod1
Registered User
 
dickwod1's Avatar
 
Join Date: Feb 2011
Location: Maxwell House
Posts: 1,250
Hi, I bought a new interlock and fitted it and its still the same,

The light area lights up correctly for spin wash pump etc. but when I press start it clicks 6 times and the red "lock" light flashes.

What should I try next try next? The PCB?
dickwod1 is offline  
15-10-2012, 18:49   #9
anuprising
Registered User
 
Join Date: Nov 2011
Posts: 367
Quote:
Originally Posted by dickwod1 View Post
Hi, I bought a new interlock and fitted it and its still the same,

The light area lights up correctly for spin wash pump etc. but when I press start it clicks 6 times and the red "lock" light flashes.

What should I try next try next? The PCB?
fault code said heater relay that's on pcb so try that as previously advised
anuprising is offline  
Advertisement
15-10-2012, 18:59   #10
dickwod1
Registered User
 
dickwod1's Avatar
 
Join Date: Feb 2011
Location: Maxwell House
Posts: 1,250
Quote:
Originally Posted by anuprising View Post
fault code said heater relay that's on pcb so try that as previously advised
Hi thanks for your help and all the replys, any suggestions on how to try the PCB as in what do I look for on the circuit board or how do I test for faults etc.
(I know how to get at it I just dont know what im looking for on it)
dickwod1 is offline  
16-10-2012, 00:26   #11
dickwod1
Registered User
 
dickwod1's Avatar
 
Join Date: Feb 2011
Location: Maxwell House
Posts: 1,250
I took off the control panel and took out the PCB and had a look at it all seems fine put everything back together and pressed start and the same 6 clicks and lock light flashes.

The light panel is clear and when I turn the main dial to wash one light lights and if I turn it to pump a different light lights and if I turn it to dry a different light lights up so I think(with my lay opinion)the control panel/PCB is working ok the washer/dryer just cant seem to recognize the door if its open or closed

Any ideas what to do

Any more help welcome
dickwod1 is offline  
Post Reply

Quick Reply
Message:
Remove Text Formatting
Bold
Italic
Underline

Insert Image
Wrap [QUOTE] tags around selected text
 
Decrease Size
Increase Size
Please sign up or log in to join the discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search



Share Tweet