Boards.ie uses cookies. By continuing to browse this site you are agreeing to our use of cookies. Click here to find out more x
Post Reply  
 
Thread Tools Search this Thread
03-10-2012, 20:32   #1
DylanII
Registered User
 
DylanII's Avatar
 
Join Date: Jul 2012
Location: Dublin
Posts: 1,019
Ford Focus - shaky and lack of power

Hi,
My ford focus suddenly got very shaky when idle/low revs and has a lack of power in low revs.

Its a 2001 1.6. Any idea what it could be? There was also a slight burning smell outside the car. I checked for coolant and oil and its fine.

Just minutes after I got a free breakdown kit with car wash! I drove home on it, the engine light started to flash, I was about to pull over but while stopped at lights it went off. Then came on again solid. Then started to flash. Its just stuck on now.

Thanks.
DylanII is offline  
Advertisement
03-10-2012, 20:33   #2
George Dalton
Registered User
 
Join Date: Oct 2011
Location: Daltons.ie
Posts: 3,452
Sounds like the usual coilpack failure.
George Dalton is offline  
04-10-2012, 11:46   #3
Larbre34
Registered User
 
Join Date: Jun 2011
Location: Dublin 15 - Dublin/Meath/Kildare borders
Posts: 2,930
Quote:
Originally Posted by George Dalton View Post
Sounds like the usual coilpack failure.
Thats exactly it, my former partners one gave up when I was driving her Focus in lane 2 of the M50, the hairy experience that followed is the reason shes my former partner. Ah it isnt really

Simple enough fix, €80 or so
Larbre34 is offline  
04-10-2012, 11:52   #4
Kenny Logins
Registered User
 
Join Date: Sep 2010
Posts: 5,208
Would a coil pack failure always light the CEL?
Kenny Logins is offline  
04-10-2012, 11:57   #5
working fool
Registered User
 
working fool's Avatar
 
Join Date: Oct 2011
Location: meath
Posts: 712
My sisters one did this too
The engine was steam cleaned and the plug leads got wet inside the engine casing the steam couldn't escape .
I just pulled out the leads and let it dry out
Was bang on after an hour .
It did put the engine warning light on .

Coil pack is a common problem
U might get lucky with the dampness thing first
working fool is offline  
Post Reply

Quick Reply
Message:
Remove Text Formatting
Bold
Italic
Underline

Insert Image
Wrap [QUOTE] tags around selected text
 
Decrease Size
Increase Size
Please sign up or log in to join the discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search



Share Tweet