Stiff brakes - no respring - boards.ie
Boards.ie uses cookies. By continuing to browse this site you are agreeing to our use of cookies. Click here to find out more x
Post Reply  
 
Thread Tools Search this Thread
04-03-2012, 13:03   #1
thechanger
Closed Account
 
Join Date: Nov 2011
Posts: 61
Stiff brakes - no respring

My Shimano Ultegra front brakes are stiff with no re-spring. I initially thought it might be the cables, so changed and lubed both inner and outer cables but no luck.

So now when pressed, they remain touching the rim. The brakes and bike are 2.5 years (About 15,000 km). Is this fixable or is this the normal lifespan of brakes?

Thanks

Last edited by thechanger; 04-03-2012 at 13:12. Reason: Add more info
thechanger is offline  
Advertisement
04-03-2012, 13:25   #2
cdaly_
Registered User
 
Join Date: Sep 2009
Posts: 4,840
First thing I'd do is wash the caliper pivots with WD40 while working the calipers in and out (take the wheels off for this). That should be enough to free them up. Then lubricate generously at the same pivot points. If you're any way mechanically inclined, you could consider dismantling, cleaning, lubing and reassembling. The pivot bolts should be tight enough to prevent rattle but not so tight as to prevent free rotation.
cdaly_ is offline  
Thanks from:
04-03-2012, 14:10   #3
thechanger
Closed Account
 
Join Date: Nov 2011
Posts: 61
cdaly_, that's worked a charm. Thanks for the advice. I can't believe it never dawned on me to lube the calipers. Next time I'll wash and fully disassemble like you said.

What's the best lube to use? At the moment I just put Finish Line dry.

Cheers
thechanger is offline  
04-03-2012, 20:01   #4
cdaly_
Registered User
 
Join Date: Sep 2009
Posts: 4,840
I use the same lube as I'm using on the chain. Finish Line wet at the mo...
cdaly_ is offline  
04-03-2012, 21:37   #5
Pablo Rubio
Registered User
 
Pablo Rubio's Avatar
 
Join Date: Oct 2011
Location: North Co. Dublin
Posts: 262
Having the same problem with my rear caliper as well. Stripped & cleaned it lubed it and it was bang on a few weeks ago. Washed my bike yesterday and forgot to lube it and it seized again today. Quick squirt of wet lube and a wipe off sorted it out.
Pablo Rubio is offline  
Post Reply

Quick Reply
Message:
Remove Text Formatting
Bold
Italic
Underline

Insert Image
Wrap [QUOTE] tags around selected text
 
Decrease Size
Increase Size
Please sign up or log in to join the discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search



Share Tweet