richersounds.ie Representatives

7 hrs
Response Time
94%
Response Rate

We're online:

Monday - Friday: 9am - 5pm

LG Nanocell SM8600 TV - Freesat channels not working

06.01.2020 11:39 #1
Hi All,

First off, big thanks to Richersounds for the amazing service on my LG 49SM8600 4K TV.
Ordered late on 1st Jan via web, delivered to Dublin on 3rd Jan.

Now the not so good. 
I have a satellite dish that was previously used to receive Sky (old Sky, not SkyQ). 
I've hooked this up to the DVB-S2 tuner of the TV and was able to tune in the UK free-to-air channels such as BBC, C4, etc.

However when I click on any channel an "Invalid Service" error is returned on screen. The EPG/Channel list displays all the channels, but with a "No information" message.

So as it stands, the Freesat tuner is not working.
Can anyone advise if this is a common issue with the Nanocell TVs or webOS?

Apart from streaming Netflix/Prime, Freesat was a big requirement for me and it seems like I chose a lemon with LG !@?


Rgds,
Joe
1 thank
06.01.2020 12:16 #2
Verified representative
Originally posted by jayneemac
Hi All,

First off, big thanks to Richersounds for the amazing service on my LG 49SM8600 4K TV.
Ordered late on 1st Jan via web, delivered to Dublin on 3rd Jan.

Now the not so good. 
I have a satellite dish that was previously used to receive Sky (old Sky, not SkyQ). 
I've hooked this up to the DVB-S2 tuner of the TV and was able to tune in the UK free-to-air channels such as BBC, C4, etc.

However when I click on any channel an "Invalid Service" error is returned on screen. The EPG/Channel list displays all the channels, but with a "No information" message.

So as it stands, the Freesat tuner is not working.
Can anyone advise if this is a common issue with the Nanocell TVs or webOS?

Apart from streaming Netflix/Prime, Freesat was a big requirement for me and it seems like I chose a lemon with LG !@?


Rgds,
Joe

Hi Joe.

Sorry to hear you are having an issue with the free to air satellite stations.
This is not a fault I have came across my self I have to say.

LG are one of the few manufacturers who include a satellite tuner on their set and this is this first of this issue I have heard of.
We have sold lots of these sets so far.

We would need to drop LG a call to see if they have any ideas.
You could try them yourself as most times it helps to have the product in question in front of you for LG to go over.

Just to check that you are switching over to the satellite tuner and not still on the Freeview/Saorview tuner which could display a message like that as BBC and C4 will not display through this tuner.
When was the last time you used your dish in-case it may have moved.

WebOS is LG's smart operating system and would not have any effect on the tuners.
1 thank
06.01.2020 13:40 #3
Thanks for the quick response Kenny.

I found a thread on the LGwebos forum and it seems like a number of customers are experiencing the same problem.

It has been reported to LG already, with a very unsatisfactory response where in they're effectively blaming the broadcasters over the implementation of HBBTV.

_https://www.lgwebos.com/topic/4558-invalid-service/page/2/#comment-14826

However this is nonsense AFAIC as a number of the stations are HBB and my set is still displaying "Invalid Service" even though LG say the support the new HBB format.
Judging from the responses from other users it would seem like there is a problem with the firmware and/or webOS.

Can I ask for the current experience of other LG TV owners here on Boards?
Are you able to tune in Freesat stations and if so what's your current OS level and what satellite (Astra2?) are you tuned into and what frequencies?

Note I'm currently on the latest firmware for the SM8600, but can't confirm release at moment.

Thanks in advance!
1 thank
06.01.2020 15:29 #4
Moderator
Mod Comment


Hi jayneemac,

If you want to check this issue with other Boardies, you could post it on the Home Entertainment forums here on Boards - you could also try checking on avforums.com (a UK based site) where there might be similar experiences.

Cheers,

Ritz.
2 thanks
06.01.2020 16:16 #5
Verified representative
Hey Jayneemac.

Thanks for taking my call earlier.

To switch between the Freeview/Saorview tuner and the SAtellite tuner you need to:
Press the input button and then select live TV.
Then select list/TV guide.
Once on the EPG is up at the top you will have Filters.
Select this and then click on Freesat.
This will change to the satellite tuner.

To get back to Saorview repeat the above and select Antenna.

Let me know once you have tried the above.

You will not be able to access any UK TV stations via the Saorview/Freeview tuner due to location.
Last edited by Richersounds.ie: Kenny: 06.01.2020 at 17:02.
06.01.2020 16:53 #6
Verified representative
Hi Guys,

@The Ritz - the above issue was actually a misunderstanding HBBTV is a Freeview service ( not as the OP thought a Satellite) service so at the moment the issue appears to be resolved.

ATVB,

John Mc & Crew
2 thanks
07.01.2020 09:14 #7
Originally posted by The Ritz
Mod Comment


Hi jayneemac,

If you want to check this issue with other Boardies, you could post it on the Home Entertainment forums here on Boards 

Thanks Ritz, will do later


Originally posted by Richersounds.ie: John
Hi Guys,

@The Ritz - the above issue was actually a misunderstanding HBBTV is a Freeview service ( not as the OP thought a Satellite) service so at the moment the issue appears to be resolved.

ATVB,

John Mc & Crew

John/Kenny thanks for the call yesterday and your replies.
Unfortunately the issue is not resolved - I was switched over to the correct tuner.

So Auto Tuning - Satellite - Freesat: Finds the UK free-to-air such as BBC, C4, ITV etc and loads them into the EPG/Channel list. But clicking on any station returns a blank screen with "Invalid Service" (on sat Astra 28.3E).

I tried an alternative and re-tuned to Satellite - Other Services : this hit satellite Astra 19.2E and successfully loaded stations such as Quest HD, Bloomberg, Talking Pictures and Sky channel 999 .

This is all new to me tbh, so please bear with me as I didn't anticipate these problems and I'm starting from scratch.
Now I'm not sure if its the Dish alignment or a shoddy OS update on the TV -> as others have experienced/suggested on the LGwebOS forum.

If it was a dish issue, would it even tune in the UK freesat stations in the first instance??
Also reset to factory settings and setup the TV as UK with a valid post code, but with same results.

I don't have a set-top box to confirm or rule out the above I'm afraid, but I shouldn't have to go to the expense or trouble either!
2 thanks
07.01.2020 09:30 #8
Verified representative
Hi Jaynemac,

If you have a dish that is not correctly aligned it could give you a channel listing but not be able to display the channel picture.

Just to be clear - this is not related to the LGwebos forum issue that you posted about previously - as explained by my colleague yesterday - that related to Freeview which is not available in the ROI.

We are happy to send an engineer out to you but they will look at the TV and determine if there is any fault with the TV - they will not re-position your dish - being honest with you I have never seen an LG with a satellite tuner that could not tune in a free-to-air station with a correctly aligned dish - I do appreciate that there is always a first time but I would try to check out the dish alignment in the first instance - possibly you have a decommissioned SKY box still kicking around?

Thanks again and keep us posted with progress and we will do our best to assist,

ATVB,

John Mc & Crew
1 thank
05.05.2021 16:45 #9
Originally posted by jayneemac
Originally posted by The Ritz
Mod Comment


Hi jayneemac,

If you want to check this issue with other Boardies, you could post it on the Home Entertainment forums here on Boards 

Thanks Ritz, will do later


Originally posted by Richersounds.ie: John
Hi Guys,

@The Ritz - the above issue was actually a misunderstanding HBBTV is a Freeview service ( not as the OP thought a Satellite) service so at the moment the issue appears to be resolved.

ATVB,

John Mc & Crew

John/Kenny thanks for the call yesterday and your replies.
Unfortunately the issue is not resolved - I was switched over to the correct tuner.

So Auto Tuning - Satellite - Freesat: Finds the UK free-to-air such as BBC, C4, ITV etc and loads them into the EPG/Channel list. But clicking on any station returns a blank screen with "Invalid Service" (on sat Astra 28.3E).

I tried an alternative and re-tuned to Satellite - Other Services : this hit satellite Astra 19.2E and successfully loaded stations such as Quest HD, Bloomberg, Talking Pictures and Sky channel 999 .

This is all new to me tbh, so please bear with me as I didn't anticipate these problems and I'm starting from scratch.
Now I'm not sure if its the Dish alignment or a shoddy OS update on the TV -> as others have experienced/suggested on the LGwebOS forum.

If it was a dish issue, would it even tune in the UK freesat stations in the first instance??
Also reset to factory settings and setup the TV as UK with a valid post code, but with same results.

I don't have a set-top box to confirm or rule out the above I'm afraid, but I shouldn't have to go to the expense or trouble either!

Hi Joe, 

I've just had the exact same experience re: tuned in on my lgtv and received invalid service message, tried other option and got the Bloomberg talking pictures etc. Did you manage to resolve this and view freesat directly on the tv or did you end up having to get a seperate box?

Thanks,
cassidco
1 thank
05.05.2021 17:23 #10
Verified representative
Originally posted by cassidco
Originally posted by jayneemac
Originally posted by The Ritz
Mod Comment


Hi jayneemac,

If you want to check this issue with other Boardies, you could post it on the Home Entertainment forums here on Boards 

Thanks Ritz, will do later


Originally posted by Richersounds.ie: John
Hi Guys,

@The Ritz - the above issue was actually a misunderstanding HBBTV is a Freeview service ( not as the OP thought a Satellite) service so at the moment the issue appears to be resolved.

ATVB,

John Mc & Crew

John/Kenny thanks for the call yesterday and your replies.
Unfortunately the issue is not resolved - I was switched over to the correct tuner.

So Auto Tuning - Satellite - Freesat: Finds the UK free-to-air such as BBC, C4, ITV etc and loads them into the EPG/Channel list. But clicking on any station returns a blank screen with "Invalid Service" (on sat Astra 28.3E).

I tried an alternative and re-tuned to Satellite - Other Services : this hit satellite Astra 19.2E and successfully loaded stations such as Quest HD, Bloomberg, Talking Pictures and Sky channel 999 .

This is all new to me tbh, so please bear with me as I didn't anticipate these problems and I'm starting from scratch.
Now I'm not sure if its the Dish alignment or a shoddy OS update on the TV -> as others have experienced/suggested on the LGwebOS forum.

If it was a dish issue, would it even tune in the UK freesat stations in the first instance??
Also reset to factory settings and setup the TV as UK with a valid post code, but with same results.

I don't have a set-top box to confirm or rule out the above I'm afraid, but I shouldn't have to go to the expense or trouble either!

Hi Joe, 

I've just had the exact same experience re: tuned in on my lgtv and received invalid service message, tried other option and got the Bloomberg talking pictures etc. Did you manage to resolve this and view freesat directly on the tv or did you end up having to get a seperate box?

Thanks,
cassidco

Hi Cassidco.

This is going back a bit and I can't remember the out come of this.

We may had to send out one of our service engineers to assess the issue.

Did you purchase your set from us here at Richersounds?
05.05.2021 20:10 #11
Originally posted by Richersounds.ie: Kenny
Originally posted by cassidco
Originally posted by jayneemac
Originally posted by The Ritz
Mod Comment


Hi jayneemac,

If you want to check this issue with other Boardies, you could post it on the Home Entertainment forums here on Boards 

Thanks Ritz, will do later


Originally posted by Richersounds.ie: John
Hi Guys,

@The Ritz - the above issue was actually a misunderstanding HBBTV is a Freeview service ( not as the OP thought a Satellite) service so at the moment the issue appears to be resolved.

ATVB,

John Mc & Crew

John/Kenny thanks for the call yesterday and your replies.
Unfortunately the issue is not resolved - I was switched over to the correct tuner.

So Auto Tuning - Satellite - Freesat: Finds the UK free-to-air such as BBC, C4, ITV etc and loads them into the EPG/Channel list. But clicking on any station returns a blank screen with "Invalid Service" (on sat Astra 28.3E).

I tried an alternative and re-tuned to Satellite - Other Services : this hit satellite Astra 19.2E and successfully loaded stations such as Quest HD, Bloomberg, Talking Pictures and Sky channel 999 .

This is all new to me tbh, so please bear with me as I didn't anticipate these problems and I'm starting from scratch.
Now I'm not sure if its the Dish alignment or a shoddy OS update on the TV -> as others have experienced/suggested on the LGwebOS forum.

If it was a dish issue, would it even tune in the UK freesat stations in the first instance??
Also reset to factory settings and setup the TV as UK with a valid post code, but with same results.

I don't have a set-top box to confirm or rule out the above I'm afraid, but I shouldn't have to go to the expense or trouble either!

Hi Joe, 

I've just had the exact same experience re: tuned in on my lgtv and received invalid service message, tried other option and got the Bloomberg talking pictures etc. Did you manage to resolve this and view freesat directly on the tv or did you end up having to get a seperate box?

Thanks,
cassidco

Hi Cassidco.

This is going back a bit and I can't remember the out come of this.

We may had to send out one of our service engineers to assess the issue.

Did you purchase your set from us here at Richersounds?

Thanks for the response and apologies for any confusion, no I didn't purchase my tv from Richersounds or with this specific use in mind. I just stumbled into the same situation as Joe and was wondering if there was setting adjustment or 'quick fix' that might have done the trick. Not to worry, thanks anyway.
1 thank
06.05.2021 09:32 #12
Verified representative
Originally posted by cassidco
Originally posted by Richersounds.ie: Kenny
Originally posted by cassidco
Originally posted by jayneemac
Originally posted by The Ritz
Mod Comment


Hi jayneemac,

If you want to check this issue with other Boardies, you could post it on the Home Entertainment forums here on Boards 

Thanks Ritz, will do later


Originally posted by Richersounds.ie: John
Hi Guys,

@The Ritz - the above issue was actually a misunderstanding HBBTV is a Freeview service ( not as the OP thought a Satellite) service so at the moment the issue appears to be resolved.

ATVB,

John Mc & Crew

John/Kenny thanks for the call yesterday and your replies.
Unfortunately the issue is not resolved - I was switched over to the correct tuner.

So Auto Tuning - Satellite - Freesat: Finds the UK free-to-air such as BBC, C4, ITV etc and loads them into the EPG/Channel list. But clicking on any station returns a blank screen with "Invalid Service" (on sat Astra 28.3E).

I tried an alternative and re-tuned to Satellite - Other Services : this hit satellite Astra 19.2E and successfully loaded stations such as Quest HD, Bloomberg, Talking Pictures and Sky channel 999 .

This is all new to me tbh, so please bear with me as I didn't anticipate these problems and I'm starting from scratch.
Now I'm not sure if its the Dish alignment or a shoddy OS update on the TV -> as others have experienced/suggested on the LGwebOS forum.

If it was a dish issue, would it even tune in the UK freesat stations in the first instance??
Also reset to factory settings and setup the TV as UK with a valid post code, but with same results.

I don't have a set-top box to confirm or rule out the above I'm afraid, but I shouldn't have to go to the expense or trouble either!

Hi Joe, 

I've just had the exact same experience re: tuned in on my lgtv and received invalid service message, tried other option and got the Bloomberg talking pictures etc. Did you manage to resolve this and view freesat directly on the tv or did you end up having to get a seperate box?

Thanks,
cassidco

Hi Cassidco.

This is going back a bit and I can't remember the out come of this.

We may had to send out one of our service engineers to assess the issue.

Did you purchase your set from us here at Richersounds?

Thanks for the response and apologies for any confusion, no I didn't purchase my tv from Richersounds or with this specific use in mind. I just stumbled into the same situation as Joe and was wondering if there was setting adjustment or 'quick fix' that might have done the trick. Not to worry, thanks anyway.

Hey Cassidco.

No problem at all.
I was just checking incase we needed to arrange any repair services :)

Perhaps you could drop Joe a PM as he may not see your post on this thread.
12.05.2021 14:25 #13
Originally posted by Richersounds.ie: Kenny
Originally posted by cassidco
Originally posted by jayneemac
Originally posted by The Ritz
Mod Comment


Hi jayneemac,

If you want to check this issue with other Boardies, you could post it on the Home Entertainment forums here on Boards 

Thanks Ritz, will do later


Originally posted by Richersounds.ie: John
Hi Guys,

@The Ritz - the above issue was actually a misunderstanding HBBTV is a Freeview service ( not as the OP thought a Satellite) service so at the moment the issue appears to be resolved.

ATVB,

John Mc & Crew

John/Kenny thanks for the call yesterday and your replies.
Unfortunately the issue is not resolved - I was switched over to the correct tuner.

So Auto Tuning - Satellite - Freesat: Finds the UK free-to-air such as BBC, C4, ITV etc and loads them into the EPG/Channel list. But clicking on any station returns a blank screen with "Invalid Service" (on sat Astra 28.3E).

I tried an alternative and re-tuned to Satellite - Other Services : this hit satellite Astra 19.2E and successfully loaded stations such as Quest HD, Bloomberg, Talking Pictures and Sky channel 999 .

This is all new to me tbh, so please bear with me as I didn't anticipate these problems and I'm starting from scratch.
Now I'm not sure if its the Dish alignment or a shoddy OS update on the TV -> as others have experienced/suggested on the LGwebOS forum.

If it was a dish issue, would it even tune in the UK freesat stations in the first instance??
Also reset to factory settings and setup the TV as UK with a valid post code, but with same results.

I don't have a set-top box to confirm or rule out the above I'm afraid, but I shouldn't have to go to the expense or trouble either!

Hi Joe, 

I've just had the exact same experience re: tuned in on my lgtv and received invalid service message, tried other option and got the Bloomberg talking pictures etc. Did you manage to resolve this and view freesat directly on the tv or did you end up having to get a seperate box?

Thanks,
cassidco

Hi Cassidco.

This is going back a bit and I can't remember the out come of this.

We may had to send out one of our service engineers to assess the issue.

Did you purchase your set from us here at Richersounds?

Hi Joe, I've resolved this now, in case you get called out about this again here's what I found. The problem was that Sky replaced the LNB on the satellite dish with a specific Sky Q LNB. I've now replaced it with a Hyrbid LNB that can cater to Sky Q and FTA. Freesat works perfectly on the tv now once set up in UK mode. Thanks again.
1 thank
12.05.2021 14:28 #14
Verified representative
Hi Cassidco.

Thanks for the details.

Glad you are now up and running.
Reply to thread
Bold
Italic
Underline
Strikethrough
Align left
Center
Align right
Bullet list
Insert an image
Insert an emoticon
Insert a YouTube video
Remove Formatting
View source
Please Log In or Sign Up to join the discussion