Advertisement
If you have a new account but are having problems posting or verifying your account, please email Niamh on [email protected] for help. Thanks :)
New AMA with a US police officer (he's back!). You can ask your questions here

Advice on electric scooter fix

  • 29-07-2021 7:34pm
    #1
    Registered Users Posts: 3 ballbagmaguire


    Hello I just bought a Xiaomi pro 2 scooter and its not turning on. At first it turned on and beeped as it said it would on the manual, I connect it to the Xiaomi home app as instructed and it began downloading the update to the firmware. After it was download there was a loud beep and the display just didn't move at all and the just turned off. I tried turning it back on and nothing but the brake light keeps flashing. Any help would be greatly appreciated

    Thanks

    Post edited by Boards.ie: Niamh on


Comments

  • Registered Users Posts: 575 ✭✭✭ hamburgham


    Hi, did you get this sorted?

    I have just bought one and I can’t connect it to the Xiaomi home app at all. The app says ‘ scooter located, press power button to pair” and that’s as far as I get, nothing happens after that.

    I haven’t a clue what to do, any advice gratefully received.



  • Registered Users Posts: 575 ✭✭✭ hamburgham


    It’s ok,I’ve got it.



  • Posts: 0 [Deleted User]


    You bricked your scooter! It happens load with fake Xiaomi scooters. Just buy the replacement board and never update the firmware if it is not really needed. It is possible to re-flash the board but that service may cost more than entire board itself. I have many different programmers including st link



  • Registered Users Posts: 2,009 ✭✭✭ wait4me


    If I could ask my question on this thread. My Mi365 (not with an app) electric scooter has not been used in over a year and the battery pack has died. Is there any way of giving it a boost to get it to start charging again? When I plug the charger into the scooter it is showing green, rather than red for charging. Thanks



  • Posts: 0 [Deleted User]


    1 year not in use is too long time. I can tell to you one trick, if it works you owe me the nice cold beer. Keep the charger connected for long time (not over 24-48 hours). If it is connected, BMS pulse short cycles. Over the time all these cycles may deliver enough to increase over the minimum voltages and it start charging. If there is bad cells it never happens.

    Buying the new battery looks easy option but remember, online websites is flooded by fake batteries. The best option (I think) is to rebuild the battery pack by 18650 HG2 units. These are way better for electric scooter.



  • Advertisement
  • Registered Users Posts: 2,009 ✭✭✭ wait4me


    I'll give that a shot - thanks - will buy you two if it works!



  • Registered Users Posts: 3,135 ✭✭✭ Padre_Pio


    Another option (used to work with XBOX controllers) is to plug it in for 10 seconds, plug it out, back in for 10 seconds, back out. Rinse and repeat until the battery gets enough charge to "wake up" the BMS.



  • Moderators, Category Moderators, Motoring & Transport Moderators, Regional East Moderators Posts: 58,875 CMod ✭✭✭✭ unkel


    Both methods are worth a try, but not likely to work. What will likely do the trick is dismantle the battery pack and charge individual 18650 cells. And if that doesn't work, use one newer and charged 18650 cell (say from a torch or whatever you have around), parallel connect the two cells, leave them long enough for the low cell to gain some voltage and then charge it individually

    Big step up from those other methods, I know. Been there done that 😂

    "Wind is Ireland's oil" - An Taoiseach, 25/05/2022



  • Registered Users Posts: 1,899 ✭✭✭ deckie27


    Good advice.

    Apologies off topic

    I had an issue with the dyson cordless vac

    flashing light on BMS.

    When I checked, one cell was slightly lower voltage than the rest. Charged up all cells to full but BMS still not playing ball.

    Is there any simple way to "reset" bms?



  • Moderators, Category Moderators, Motoring & Transport Moderators, Regional East Moderators Posts: 58,875 CMod ✭✭✭✭ unkel


    Chances are the BMS is faulty, but you could always disconnect it from the pack, make sure the pack is ok, then reconnect the BMS

    "Wind is Ireland's oil" - An Taoiseach, 25/05/2022



  • Advertisement
Advertisement