Advertisement
We've partnered up with Nixers.com to offer a space where you can talk directly to Peter from Nixers.com and get an exclusive Boards.ie discount code for a free job listing. If you are recruiting or know anyone else who is please check out the forum here.
If you have a new account but can't post, please email Niamh on [email protected] for help to verify your email address. Thanks :)

Ford 3000 hydraulics

  • 10-06-2021 8:00pm
    #1
    Registered Users Posts: 857 ✭✭✭ tellmeabit


    Hi. Decided to attempt to bring this lil beauty back to life. Fingers crossed..
    Any advise on this appreciated.
    The 3 point isn't moving at all, when last running this was very slow to react, sometimes would lift and then stay up..
    The tipper is working so the pump is working.
    From googling people suggest the flow control valve and the pressure relief valve.
    Is there any way to tell if these are functioning? Hope to open it up over the weekend and see what I see. The draft control lever has snapped off so not sure what position this is in? Or how that would affect the operation..
    Any advice please?


Comments

  • Registered Users Posts: 362 ✭✭ Theheff


    tellmeabit wrote: »
    Hi. Decided to attempt to bring this lil beauty back to life. Fingers crossed..
    Any advise on this appreciated.
    The 3 point isn't moving at all, when last running this was very slow to react, sometimes would lift and then stay up..
    The tipper is working so the pump is working.
    From googling people suggest the flow control valve and the pressure relief valve.
    Is there any way to tell if these are functioning? Hope to open it up over the weekend and see what I see. The draft control lever has snapped off so not sure what position this is in? Or how that would affect the operation..
    Any advice please?

    We had a 2000 many years ago. I remember we had lift issues and it turned out to be a clogged filter. Once replaced I think it was ok.


  • Registered Users Posts: 857 ✭✭✭ tellmeabit


    Theheff wrote: »
    We had a 2000 many years ago. I remember we had lift issues and it turned out to be a clogged filter. Once replaced I think it was ok.

    Ya some folks suggest a clean out and replace the filters inside.
    I opened the level check nut and a good bit of grey oil came out so assume water in there too.


  • Registered Users Posts: 362 ✭✭ Theheff


    tellmeabit wrote: »
    Ya some folks suggest a clean out and replace the filters inside.
    I opened the level check nut and a good bit of grey oil came out so assume water in there too.

    First port of call I would suggest oil and filter. Many years they id say.


  • Registered Users Posts: 857 ✭✭✭ tellmeabit


    Got the top cover off. Found the lift cylinder with a good chunk out of it and the bar to push it bent at 90 degrees.
    I've no idea no how happened.
    Ringing around trying to find replacement cylinder but rare and expensive.
    Place in cork selling a lift cover including the cylinder. Anyone know of they are same as the 3000?


Advertisement