DEL_P_O Registered User

Hi everyone, hopefully someone can help me with this as I’m literally losing sleep over it at this stage!!
The issue is my download speeds are very fast but my upload speeds are very slow and are impacting me using Skype or logging onto work from home.
I’m using UPC 100mb broadband. My laptop is loaded with windows 7 64bit with 8gb of RAM and an i7 2.5ghz processor.
When I use the speed test facility on UPC I get on average about 60 – 70 mbph for downloads but it won’t register anything for my upload speed.
When I right click on the broadband I’m connected to and select status windows tells me I’m receiving on average 43,982,173 bytes and sending only 4,528,997 bytes.
I almost certain at this stage that this is not an issue with my broadband as I have tested this on an old laptop using windowns xp and I’m getting a good upload and download speed.
Does anyone have any advice they can give me?


I had the EXACT same problem with UPC recently, I did a little research and I found out that other UPC customers have had the same issue and the common cause was the new Cisco ISR (router) firmware.

I called and got told by level 1 tech support they would call me back. A few mins later level 2 called me back and after failing to sort it out put me through to level 3 support. They guy on the phone knew exactly what to do , he even gave me an extra 5 Mbs download speed for my troubles. After talking to him I now have the best connection I have ever had.

So the solution is to call them and try get put onto Higher levels of support to sort it. As soon as the level one support starts getting confused by your problem they will escalate the issue to the more experienced network technicians. The guy I talked to was a legend , If your lucky you'll get him to sort it.

KoolKid Moderator

I would also get your download speeds checked. You should be getting better than that on 100 meg .

DEL_P_O Registered User

@ CiscoStudent
Cheers for your reply. Tomorrow evening when I get home from work I'm going to hound UPC until they get this sorted! I'll let you know how I get on.

DEL_P_O Registered User

Just to give a quick update on this issue. Hopefully this may help others and others may be able to assist me in closing out this issue as its driving me nuts!
UPC was able to get my upload speed working again, but my download speed via wireless was severely reduced. After they “fixed” the issue I was getting about 20mb on the download and 7mb on the upload on a 100mb broadband service. If I plugged directly into the modem I was getting on average about 120mb download and between 7 – 9mb upload. These results are consistent using both UPC speed tests and
A UPC technician came out to check the connections and recommended that I was switch modems as he thought there may be an issue with the wireless signal. He gave me a new modem (identical model / make of the last modem). I am now back to square one again. I can’t get an upload speed at all but I’m getting about 55 – 65mb download speeds via wireless. If I Plug directly into this new modem I get about 120mb download speed and about 9mb upload speed. The issue appears to be with the wireless.
I have also tested this on an old laptop (Windows XP, 2GB RAM) and I’m getting a download speed of 20mb and an upload speed of 7mb via wireless.
Could the issue be the wireless signal from my new laptop? I’m using Windows 7 on that one. Everything was working fine with this laptop before I got upgraded to the 100mb package with UPC however. I have been on the phone most nights with UPC for the past 2 – 3 weeks and they can’t seem to resolve this.
Does anyone have any suggestions?

who_me Registered User

It could be down to your laptop's Wifi specs, or the Wifi router's configuration... or just a really dodgy router. Sorry if the below gets confusing.

If your laptop has 802.11a or 802.11g wireless, the max bandwidth is likely to be around 54Mbps, but in real life the max would be about 20Mbps.

If you have the faster 802.11n wireless the max bandwidth is 300Mbps (but I doubt if you'd actually see more than 100Mbps).

Configuration of the router can also be a factor. If you have an N router, the ideal is to have it on the 5GHz frequency, with wide(40MHz) channels. However, lots of older devices can't connect to 5GHz routers, so you might have to use the 2.4GHz frequency instead. Because there's a lot more interference at that frequency, it's generally best not to turn on the wide channels, so your max theoretical speed would be about 144Mbps, real-life maybe 30Mbps?

You probably won't get the most out of your 100Mbps connection even with the N router 5GHz/40MHz channels ideal scenario. I've no idea what's happening with your uploads though, never seen anything like that.


You should expect that wireless will be a little slower to a lot.There are many things to consider with a wireless signal. For example walls reduce signal range, Metal walls block it altogether, Microwave ovens, Plasma TV's and other electrical devices can interfere with the signal.

Now obviously you should be getting some upload speed, so it's possible you might have to do a little tweaking.

Here is a little info about the wireless standards (From Cisco):
802.11a - 54 Mbps (Max possible data rate) Range = 50 meters
802.11b - 11 Mbps (Max possible data rate) Range = 100 meters
802.11g - 54 Mbps (Max possible data rate) Range = 100 meters

*802.11n - 540 Mbps (Max possible data rate) Range = 250 meters

*These values can vary widely

That's the tech briefing, now for the troubleshooting.


To find out what your laptops wireless adapters 802.11 standard is click on Start, and right click on my computer, select properties, then hardware, then Device Manager.

Click on Network adapters, and right click on your wireless adapter. The name should indicate if Wireless n is supported, if it doesn't right click on the adapter and then click properties followed by Wireless mode. there will be a little box on the right where you can select the mode. Make a note of the wireless mode it is set to.


If possible connect your laptop over the wireless LAN. Then, click start and in the 'search for programs and files' field, type: cmd and hit enter.

Select the command prompt (cmd) option and when you get the black window on screen type: ipconfig and hit enter.

Now note the ip address of the DEFAULT GATEWAY.

Open up your web browser and in the url address bar enter that ip address (no need for www's or http's) and hit enter.

This should bring you to the wireless routers GUI (graphical user interface)

From here it is possible to change the configuration of your wireless router.

You will be prompted for a username and password. depending on the model the default credentials will be different. Sometimes the prompt gives you the default, if it does enter these in the username and password fields. Also worth trying admin in both fields, and username: admin and password:1234

If the above don't work, post the model of your router and I can try get the default login details for you.

If you get this far let me know and we will take it from there.


Go into your power saving settings in win 7, advanced settings, disable any power saving options for your wireless card both for plugged in and on battery settings. Restart laptop, try again.

DEL_P_O Registered User

Who Me, Mance Rayder, Oxo - Thanks for your suggestions. I'm going to go through these tomorrow and I'll let you know how I get on. Thanks again for your suggestions!


No probs man. Everyone forgets the poxy Power Saving options, damn thing can wreck your wireless connection.

To be more specific though, you're looking for "Wireless Adapter Settings" within the "Advanced settings" of Power Options, available after you select whatever power plan you use and click "change plan options". All of this available initially from the "Power Options" in Control Panel.

Set the "power saving mode" to "Maximum Performance" - Click OK.

Do this for all power plan settings you use, honestly, even if on battery, it's so feckin' annoying to have it on any power saving setting no matter how much power it might save you.

Reboot just to be on the safe side after changing what you did, should be no need but do it anyway, it's windows

If all the above is too much for you, or is confusing at all, just select the "High Performance" power plan at the Power Options main screen, that should by default have the wireless card set to maximum performance.

Eh, to confuse thing maybe a little, if your wireless network card is usb based (like a usb dongle or whatever) you will also need to change the "USB Selective suspend setting" to "Disabled" - even on high performance plan it's set as Enabled. Just sometimes it has an arse of a habit of suspending your USB slots, including that with which you have a USB wireless card plugged into. Again, it's Microsoft and it's Windows - if it were Linux and Ubuntu someone would've figured the settings were muck and released a fix the day after

Want to share your thoughts?

Login here to discuss!