paultronix Registered User
#1

i have here a 2001 nissan primera td which is an intermittent starter and giving a fault code for the immobiliser as P1612 chain of ecm-immu which appears to be a communication error between them,has anyone come across this before and is there a known fix as in maybe a wiring issue?
thanks.

#2

paultronix said:
i have here a 2001 nissan primera td which is an intermittent starter and giving a fault code for the immobiliser as P1612 chain of ecm-immu which appears to be a communication error between them,has anyone come across this before and is there a known fix as in maybe a wiring issue?
thanks.


First try this: http://www.npoc.co.uk/forum/nissan-primera-p11-144-reset-or-deactivating-nats_topic46460.html

crosshair1 Registered User
#3

Cant tell if its applicable to a p11 but have seen lots of n16 almeras faulting similarly, and a blast of contact cleaner to the reader coil unit & plug seems to cure, I find this so common that I dont even fault read them. (I cant recall if it was a p1612 or 1610 that was stored - also wurth contact ol is what i use)

paultronix Registered User
#4

thanks to both for you're reply's and since the original scan i now have a 2nd fault code of p1610 which i will try the method paddyp posted tomorrow.
So far i have tested the key and no faults there,tried a c/u initialisation using x431 but it fails every time,have checked for bad solder joints in immobiliser and ecm and all appears good so next i'm going to start checking voltage supplies and will also try a drop of contact cleaner as you clearly know nissans alot better than me crosshair 1 and you're experience is much appreciated.
thanks again and will keep you posted.

paultronix Registered User
#5

all fixed now and thanks to you both for you're help,i downloaded the p11 service manual today which was excellent and lead me to a broken wire between immobiliser box and ecm,(orange),also got to program a spare key too so happy out today.

Want to share your thoughts?

Login here to discuss!