Pat Mustard Category Moderator
#1

The retractable mouse for my laptop stopped working during the week. (This is not the problem).

However, the touchpad wasn't working properly this morning. It was not totally unresponsive but still quite unresponsive. It was very hard to move it accurately, and most of time the cursor wouldn't move at all. When I could move the cursor, I accidentally selected things that I didn't want to select, etc.

The touchpad seemed to work fine last night.

The laptop is a 3 year old Lenovo n500 running on Windows Vista.

After I found that the touchpad was not working properly this morning, I bought a new mouse. The new mouse works fine.

I checked Control Panel and I was told that the pointing device is working ok. I tried to update drivers for the pointing device and mouse but was told that drivers are up to date.

I ran a quick Malwarebytes scan which reported no malicious software on the computer.

I've tried function keys and the button which switches touchpad functionality on and off. These are not the source of the problem.

I've tried switching the computer on and off.

The touchpad still doesn't work properly in safe mode.

Nothing has worked so far.

My guess is that the touchpad is kaputt. Any other thoughts or suggestions on this?

If the touchpad can and should be physically repaired, does anyone know how much this is likely to cost?

Allyall Registered User
#2

Did you try this button? (Sorry, but asking to eliminate it first)

http://support.lenovo.com/en_US/detail.page?LegacyDocID=MIGR-71738

Pat Mustard Category Moderator
#3

Yes, I tried that. That's not the problem.

Allyall Registered User
#4

Is it the original battery and Power cable?

Did you install the ALPS driver, (NOT the synaptics one)? Both drivers are included when you download it. Uninstall the synaptics one first (If you installed it), then Extract the files and go to c:/drivers/touchpad/52tp10ww/alps/setup.exe

Run that one.

Then:
1- Open run and type" msconfig " then press Enter.
2- Choose startup from System Configuration window.
3- Select Alps Pointing device driver.
4- Apply then restart.

1 person has thanked this post
Pat Mustard Category Moderator
#5

The touchpad is working perfectly again, but I didn't do a thing to it. I can't understand why, unless there's a loose electrical connection somewhere, which got loose and then fell back into place.

Thanks for your reply though. I'll might try that if the problem happens again.

Pat Mustard Category Moderator
#6

Allyall said:
Is it the original battery and Power cable?



The original battery is still in the laptop.

However, sometimes I use a spare power cable, which is not a lenovo product. I've now found that the spare power cable is the cause of the problem.

The touchpad doesn't work with the spare power cable anymore, even though it used to. The touchpad works fine with the original power supply or if it is running on battery.

Want to share your thoughts?

Login here to discuss!