johnmacward Registered User

Hello all,

Like a lot of people I'm not a fan of company issued modems / routers as they are unreliable and prone to rapid failure, so I bought a Draytek Vigor 120 for some reliable DSL.

Although I'm having a lot of grief getting it working well on Vodafone Ireland broadband.

There are two modes: PPPoE and MPoA and I would like to get it working through PPPoE where the device can handle PPP authentication but I can only get it working through MPoA mode which passes the PPPoE traffic straight to the client device. This isn't a big deal really but I'd like to get it working to rule out the next problem.

In MPoA mode the broadband is very unreliable, there are frequent disconnects, high latency (800ms plus average) and big bandwidth drops from 6Mbps to 1Mbps.

I'm using the company default settings of PPPoE, VPI 8, VCI 35, LLC SNAP, Multimode in all modes and still not much luck.

Anyone had any luck configuring one of these for Vodafone Internet.

roast Registered User

In PPPoE mode, is it connecting at all?
What username and password are you using?
Vodafone use a generic username and password to authenticate. The username is and the password is broadband.
Also, the Multiplexing is LLC/SNAP if you haven't set that.

1 person has thanked this post
johnmacward Registered User

Thanks for the response "roast"!

In PPPoE mode I get nothing, all the above is set (VPI 8, VCI 35, LLC, Multimode) with one difference; our username and password is not actually entered on the Vigor modem, it's entered on the wireless router behind and this only works when it is set to MPoA mode.

They have documentation where it shows PPPoE mode and a username and password section for authenticating at the modem and (I assume) handling the public IP there and NAT'ing it to the routers and clients behind. It doesn't exist on my model for some reason.

roast Registered User

Just had a quick read through the manual there. The device only acts as as a PPPoE/A bridge or in MPoA mode. It doesn't authenticate a connection. As the Vigor is connecting OK through MPoA mode, we can assume the Vigor is fine.
What router are you using (behind the vigor) to authenticate the connection?

1 person has thanked this post
johnmacward Registered User

It depends what docs you read and most of them show a PPPoE connection with authentication happening on the modem (all these look slightly different from my build of firmware to be fair, but then again they should be updated). On page 85 of this it's defined: - It's User Guide to the left if you're interested.

It doesn't really bother me where auth occurs, I'd actually prefer it to happen on the PPPoE client which is an Asus RT-56U If memory serves me. It's a simple wireless router - WAN, 4 LAN, A, B, G, N wireless.

I had two testing scenarios. The Asus and a MacBook Pro both set to PPPoE mode and getting nothing out of PPPoE passthrough mode. Change it to MPoA and both can connect to a very dodgy connection.

It could very well be Vodafone who are serving up a crap connection (for years it was absolutely fine) but it's hard to talk to them with non-standard hardware in the gaff hence why I need to understand of it's just configuration first.

yuloni Registered User

Sorry for digging up an old thread

OP, did you ever manage to get the 120 working on PPPoE?

I recently bought 3 Vigor 120's (v.2 models) and 1. they have less functionality than their predecessors (your model) and 2. I could only get them working on MPoA and have our Draytek 3900 handle PPPoE authentication

It seems okay I guess but opinion seems to be divided on using MPoA

johnmacward Registered User

Here's the lowdown now - we got UPC internet, 50Mbps and will never go back to that atrocious DSL ever again.

Ultimately I never got it to work on PPPoE, the last thing it was left on was MPoA and once again the connection was very flaky - it worked 50% of the time. Everything I tried, I could not get it to sync with PPPoE, PPPoE with auth or any other mode apart from MPoA. MPoA was the only thing that would bridge the PPP connection to the Router for auth.

SO the conslusion is, forget about DSL, get fibre.

Want to share your thoughts?

Login here to discuss!