Podge2k7 Registered User
#1

I have it for over a year now, and I plugged it into my laptop today for the first time in a while and it made the noise as to say its been read, but I can't view anything on it and its not showing up in My Computer. The drive lit up but didn't make any noises?

Its packed with movies, music, documents and the like, which are no longer on any other of my drives, so not being able to it access will make me feel .

The drive is a 500gb Buffalo HD-PE500U2 is that helps.

Anyone know what the problem may be? Thanks.

Squaredude Registered User
#2

Is it showing in device manager?Have you tried it on another laptop?

#3

I had an old MP3 player that I hadn't used for a year, I plugged it in and it would make the noise and charge but it wouldn't show up in My Computer as a removable disk.

I went to Disk Manager and it was listed there and with a warning sign beside it. I unistalled it, removed it and plugged it back in and let the drivers reinstall and it worked.

Try it if it comes up in Device Manager
Search for it in 7 or Vista, XP: Right click My Computer in Start Menu, click properties, Hardware tab and click Device Manager

#4

Some times the problems will be in the USB ports. Try connect the device with other system then if it works then its the problem of the USB.

PrzemoF Registered User
#5

Boot a linux LiveCD and check if there is anything reported on PC side.
"lsusb" will tell you if your PC sees the drive.
I've no idea how to do it on windows...

Podge2k7 Registered User
#6

Thanks for the suggestions.

I'v tried the drive on another computer and it didn't work.

Also its not showing up in device manager or disk management.

Is there any hope of me retrieving my files?

Squaredude Registered User
#7

This isn't the most technical advice but try giving the hdd a good shake and plug it in and see what happens.managed to get an old hdd up and running like that.You could also try this and see if you have any luck http://www.acronis.com/homecomputing/products/diskdirector/

PrzemoF Registered User
#8

This thread [1] suggests that winblows (ooops, typo ;-) might have some problems if the partition is corrupt. You might try gparted as well just to check the disk.


[1] http://www.boards.ie/vbulletin/showthread.php?p=77741259#post77741259

riclad Registered User
#9

The drive pcb, maybe damaged,you could buy a sata or ide caddy and take out the hardrive ,Plug it in to caddy ,plug caddy into usb port.
most drives are sata type, Google ide and sata interface to check the type ,eg sata 2.5inch caddy.The data or power cable to the drive inside the case may be loose.

Want to share your thoughts?

Login here to discuss!