tatranska Registered User
#1

I've installed the theme Zee Personal and am having problems with the permalinks.

I want to get this

http://imaalautoservices.ie/index.php/home/

http://imaalautoservices.ie/aboutus

But am getting this

http://imaalautoservices.ie/index.php/home-page/
http://imaalautoservices.ie/index.php/about-us/


These are the permalinks when I go in to the page in the dashboard

Permalink: http://imaalautoservices.ie/index.php/home/
Permalink: http://imaalautoservices.ie/index.php/about-us


Can anyone help me sort this out.
Its the first time Ive seen /index.php/ turn up when setting permalinks

I'm hosting on Blacknight.

thanks in advance

red_ice Registered User
#2

tatranska said:
I've installed the theme Zee Personal and am having problems with the permalinks.

I want to get this

http://imaalautoservices.ie/index.php/home/

http://imaalautoservices.ie/aboutus

But am getting this

http://imaalautoservices.ie/index.php/home-page/
http://imaalautoservices.ie/index.php/about-us/


These are the permalinks when I go in to the page in the dashboard

Permalink: http://imaalautoservices.ie/index.php/home/
Permalink: http://imaalautoservices.ie/index.php/about-us


Can anyone help me sort this out.
Its the first time Ive seen /index.php/ turn up when setting permalinks

I'm hosting on Blacknight.

thanks in advance


There are a few factors to take into consideration here. Is the hosting shared? Are you using a windows server or a linux server?

Lets say you are using the shared hosting package.

I had an issue when installing wordpress via the siteapps option that they provide you with. If you have use siteapps to install wordpress, backup your database, but leave out the config table of the wordpress install. Then delete the wordpress site app from the server.

Then do a manual install of wordpress. Unzip the files to the root folder, then setup your DB, and install wordpress.

Heres where linux v windows comes in. With windows you have to create a web.config file, which from personal experience is a pain in the arse to work with.

If its linux, you create a .htaccess file, set the permissions (via ftp) to 0777 (i think?)

You want to use pretty permalinks by the looks of things. This is done by selecting the last option in permalinks and putting in %postname% in the text box.

Click save, you should get a notice on the top of the screen saying your htaccess file has been updated.

Change permissions of the htaccess file back to 755.

I would advise working with linux if you are not already, its a much better user experience imo. Blacknight will change your hosting package for you to linux if you are on windows.

Hope that helps.

tatranska Registered User
#3

Thanks for you reply red ice

Ive got a windows package but will contact BN to move over to linux.

I had it hosted on godaddy.com but never had the same issue with the permalinks. it was linux.

Could windows/linux have a bearing on the whole thing?

I've contacted them to change over.
Does their supprt team work over the weekend?

I really dont want to go down the line of manually uploading wp.

I tried the %postname% earlier but it wasnt holding in the settings.

tramoreman Registered User
#4

you might want to check the html code might be something simple

red_ice Registered User
#5

tatranska said:
Thanks for you reply red ice

Ive got a windows package but will contact BN to move over to linux.

I had it hosted on godaddy.com but never had the same issue with the permalinks. it was linux.

Could windows/linux have a bearing on the whole thing?

I've contacted them to change over.
Does their supprt team work over the weekend?

I really dont want to go down the line of manually uploading wp.

I tried the %postname% earlier but it wasnt holding in the settings.


Make sure you back anything of value up before you change over. Because everything, and i mean EVERYTHING, will be lost when you change over. Its possible to sort it out on windows, so its not down to the operating system... its just linux imo, is better and all you have to do is the couple of steps i typed up earlier and it will be sorted.

Just out of interest, try %sample-post%. See if that works. I dont think they work over the weekend.

tatranska Registered User
#6

Spoke to my lecturer today . Seems it a windows problem not found with linux .
She suggested the HTC file being changed as red ice suggested.
I was in touch with bn today and they need to talk to accounts on Monday .
Nothing important is hosted yet so I don't mind loosing it.

Will keep you updated

red_ice Registered User
#7

tatranska said:
Spoke to my lecturer today . Seems it a windows problem not found with linux .
She suggested the HTC file being changed as red ice suggested.
I was in touch with bn today and they need to talk to accounts on Monday .
Nothing important is hosted yet so I don't mind loosing it.

Will keep you updated


Drop the windows box, move to linux in that case.

Your lecturer is wrong tho. It can be solved in windows. There's no doubt, its just a longer process to fix than it is with linux.

You can speed up the process by canceling the order in the billing section of cp.blacknight.com. You're going to have to do this anyway when you talk to them. They will credit your account the ammount owed, then you can buy the linux server from the manage resources section of the billing tab.

dizzyg Registered User
#8

I had this problem one of my sites, hosted on a r365 linux account.

This link sorted it for me:
http://www.register365.com/knowledge/hosting/new/linux_hosting/1119-wordpress_rewrite_script.html

It seems some flavours of linux don't use the htaccess file for rewrites.

tatranska Registered User
#9

I've moved over to linux and the problem is sorted

But another one has arisen


when I enter http://imaalautoservices I get the following message

Domain Default page
If you see this page it means that IIS Domain Service for this domain is locked, or there's no such IIS Domain Service registered in Parallels Operations Automation.
For more information please contact your service provider.


All the other pages work fine e.g http://imaalautoservices.ie/about-us/

red_ice Registered User
#10

tatranska said:

Domain Default page
If you see this page it means that IIS Domain Service for this domain is locked, or there's no such IIS Domain Service registered in Parallels Operations Automation.
For more information please contact your service provider.


All the other pages work fine e.g http://imaalautoservices.ie/about-us/


IIS is windows. Either you are still on a windows package... or you have the site stored in cache. hold ctrl then press f5. Looks like its working to me

tatranska Registered User
#11

thanks for all your help.
I tried it on another laptop this morning and it worked fine.

It was most probably a caching problem while it was moving over from windows to linux.

red_ice Registered User
#12

no problem, glad to have been some help!

benbob65 Registered User
#13

I have a very similar problem (all my links point to my homepage in stead of the pages I want), should I start a new thread on it, or would it be ok to tag it onto this one?

Trojan Ask me about websites
#14

Start a new thread. Looks like the problem the OP had was trying to do rewrites on a Zeus webserver (a pain in the ass).

Want to share your thoughts?

Login here to discuss!