fionny Registered User
#1

Hi All,

So I managed to get Wake on LAN working when im on the local network last night using my phone, it works perfectly.

However when I am on an external network I cannot wake the computer.

I have currently forwarded port 9 to my PC (though how does the router know which one when the computer is off (static ip configured))

I have DynDns sorted on the modem to forward the external ip to a hostname and I have pinged said host and it is correctly pointing to my connection. I also know that its correct as I can access the modem remote management (albeit user name and password isnt working for unknown reason on remote only)

I have correctly entered the MAC address of the computer to be woken so I am now at a loss as to why I cannot get it to wake.

Any suggestions?

My router is the Thomson Modem / Router UPC provide with 100meg connections.

Thanks,
Fionn

#2

https://secure.dslreports.com/faq/6790

WoL tool allows you to wake a computer remotely over the Internet through a browser. On this page they indicate UDP port 9 is what the tool uses, but as of this writing the magic packet is actually sent through UDP port 32767. So, if you're using this tool be sure to forward port 32767 through the router.


Try opening port 32767 to UDP too.

Also, you may need to assign a static IP address to your pc by MAC address to ensure that it's always the same IP address, so that when you open port 32767 it gets routed to eg. 192.168.1.102

fionny Registered User
#3

Thanks ill try that tonight, I have a static IP configured in Windows there is no method that I am aware of on the Modem of forwarding to a MAC address though.

fionny Registered User
#4

Okay so to come back to this,

I had the WoL working externally for a time but it randomly stops working for no apparent reason. I have the right IP and MAC address and the ports are forwarded correctly but it will not wake.

I can then log into the router/modem (on the local network) and it will start working again so I assume that the router is blocking it somehow? Its a UPC Thomson modem / router. Any ideas?

vibe666 Registered User
#5

never actually tried it, i have WoL on my router, so i log into that remotely and use it from there to wake up PC's on the LAN and it works every time. not the solution you are looking for i know, but it might be something to think about for the future.

fionny Registered User
#6

vibe666 said:
never actually tried it, i have WoL on my router, so i log into that remotely and use it from there to wake up PC's on the LAN and it works every time. not the solution you are looking for i know, but it might be something to think about for the future.


I would if I could but my router doesn't have the option and I dont really have the money or the inclination to buy a new one. Ill struggle on im sure

vibe666 Registered User
#7

if its a regular thing, would it be feasible to set a wake alarm in the bios of the pc('s) in question?

fionny Registered User
#8

Nah its just when and if I wanted to wake it to remote desktop in.

vibe666 Registered User
#9

did you try a low power suspend instead of a shutdown? might be more reliable that way maybe?

1 person has thanked this post
fionny Registered User
#10

Will try that tonight and see if it makes any odd's, cheers

vibe666 Registered User
#11

depending on your motherboard, it should support various suspend states, so give them all a test drive and see how you go.

1 person has thanked this post
fionny Registered User
#12

Thing is it will ALWAYS wake when im on the local network... so that leads me to believe it might be the modem / router blocking it?

vibe666 Registered User
#13

fionny said:
Thing is it will ALWAYS wake when im on the local network... so that leads me to believe it might be the modem / router blocking it?
could well be. can you get remote access to the router?

i was just wondering if you could do that, maybe a reboot of the router before the WOL request might fix the problem? probably like using a hammer to put in a screw, but it might work.

1 person has thanked this post
freelancerTax Registered User
#14

the reason it seems to work randomly is because after a certain amount of time when you shut down the computer the router "forgets" the machine and no longer routes packets to it , to solve this you simply need to force tbe router to send the wake up packet to all devices attached to it

you can do this by forwarding to the broadcast address of your network
this is usually as follows

if your ip is 192.168.1.x then the broadcast address is likely 192.168.1.255
but it will depend how your router is configured
so you should be able to port forward to that address instead of the machines ip and it shold work all the time


works for me anyway

2 people have thanked this post
fionny Registered User
#15

@Vibe666:

I cant log into the router externally because for some reason the Username and Password are different to when you log in on the local network and I cannot find hide nor hair for it. I even posted on boards and got nada.


@FreelancerTax

I will try that solution out and come back to you

Want to share your thoughts?

Login here to discuss!