boyoh Registered User
#1

Hello, I need a bit of help. I think my glow plug relay is gone,but can anyone tell me which one is for the glow plugs as there is a row of them in the glove box beside the fuses. Do I need to get this from a Main Dealer ?
Fiat Ducato 1992 2.5 left hand drive. Thanks, i just know someone has this little bit of information..................boyoh

#2

boyoh said:
Hello, I need a bit of help. I think my glow plug relay is gone,but can anyone tell me which one is for the glow plugs as there is a row of them in the glove box beside the fuses. Do I need to get this from a Main Dealer ?
Fiat Ducato 1992 2.5 left hand drive. Thanks, i just know someone has this little bit of information..................boyoh


Is it not out under the bonnet up over the battery a big yoke. Your best bet a scrap yard as they go big money on ebay and as far as I know are no longer available from fiat. It you can get the numbers off it you might be able to get it from iveco. The cheapest solution is a switch and a relay and counting it yourself. Some of the germans have wired the flame start similarly and manually pulsed the switch don't reckon you'll ever need the flame start here though.

the rambler Registered User
#3

are you sure its a glow plug relay that you need? (not doubting you)
as i tried every thing with mine and it took an auld timer to come up with an auld solution
try putting a non return valve (€10 from motor factors) on the feed pipe from the tank just before the diesel filter, as it might be letting the diesel back to the tank after a few hours after being turned off,
it cured mine and my neighbour had similar probs and it sorted him out as well,

hope this might be some help,http://cgi.ebay.ie/8mm-Fuel-one-way-valve-petrol-diesel-non-return-carb-/350472455596?pt=UK_CarsParts_Vehicles_Boat_Engines_EngineParts_SM&hash=item5199c945ac

#4

the rambler said:
are you sure its a glow plug relay that you need? (not doubting you)
as i tried every thing with mine and it took an auld timer to come up with an auld solution
try putting a non return valve (€10 from motor factors) on the feed pipe from the tank just before the diesel filter, as it might be letting the diesel back to the tank after a few hours after being turned off,
it cured mine and my neighbour had similar probs and it sorted him out as well,

hope this might be some help,http://cgi.ebay.ie/8mm-Fuel-one-way-valve-petrol-diesel-non-return-carb-/350472455596?pt=UK_CarsParts_Vehicles_Boat_Engines_EngineParts_SM&hash=item5199c945ac


Good thinking, often leak back is caused by the injector return pipes gone porus I replace them by default as its only about 80c a meter.

boyoh Registered User
#5

Thanks lads. but i don't have any glow plug light on the dash and i don't have any lights,the whole thing is a mystery as i held glow plug coil in but there did not seem to be fuel going to the engine, there must be a relay that controls power to the glow plug relay and the fuel solenoid, but not having a manual it's hard to know..................boyoh. Oh! and i did check the fuses.

#6

boyoh said:
Thanks lads. but i don't have any glow plug light on the dash and i don't have any lights,the whole thing is a mystery as i held glow plug coil in but there did not seem to be fuel going to the engine, there must be a relay that controls power to the glow plug relay and the fuel solenoid, but not having a manual it's hard to know..................boyoh. Oh! and i did check the fuses.


If its drained back far enough you'll need to crack and injector pipe at the pump to bleed the air out of it.

boyoh Registered User
#7

Found the problem lads.The ignition has a double live, and the feed to the glow plug relay,fuel solenoid and lights is on the side that went down, so now i have to find a new switch,thanks for all the advice...........boyoh

#8

boyoh said:
Found the problem lads.The ignition has a double live, and the feed to the glow plug relay,fuel solenoid and lights is on the side that went down, so now i have to find a new switch,thanks for all the advice...........boyoh


If its not too badly burned you can often sandpaper the contacts and it will probably work away for another 20 years.

the rambler Registered User
#9

if you are finding it tough finding parts have a look on done deal as theres a few lads breaking the early 90's ducato's
one lad in donegal has an add in regular enough and another is around tipperary i think,
happy camping.

Aidan_M_M Registered User
#10

get some contact cleaner and give a good squirt of it into the contacts , might help. Worst case scenario , put a push button switch on the dash to switch on the relay .

#11

Aidan_M_M said:
get some contact cleaner and give a good squirt of it into the contacts , might help. Worst case scenario , put a push button switch on the dash to switch on the relay .


I was going to say that hide a switch up under the dash like a 1960s 'immobiliser' my dad old audi bangers always had one

the rambler Registered User
#12

did you find out what the problem was in the end??

jdee99 Registered User
#13

Aidan_M_M said:
get some contact cleaner and give a good squirt of it into the contacts , might help. Worst case scenario , put a push button switch on the dash to switch on the relay .


Apologies for resurrecting this old thread but I have just brought a 1993 Hymer based on Fiat Ducato (2.5 non turbo). I have the same problem as the OP in that the glow plugs light briefly illuminates and then goes out. I have just had a nosey around and discovered that there is a push button switch on the dash - at a guess I assume that this is to switch on the glow plug relay. Can you enlighten me on how long the push switch needs to be held in for - is the same length of time as the normal glow plug operation.

Up to now it has started first time every time!

Many thanks

Want to share your thoughts?

Login here to discuss!