Milliehollie Registered User
#1

Just wondering if anyone can help me. I have a seagate external hard drive for the past 2-3years. It has alot of sentimental photos on it and stupidly it is the only place i have these photos.

It has been working fine until yesterday I plugged it into my laptop and it now it is showing up on my computer but when I click on it I am getting the following message "Location is not available. G:/ is not accessible. The parameter is incorrect" It also says "you need to format the disk in drive G: before you can use it. Do you wan to format it?" When i tried everything else I said yes to formating but then didn't go ahead with it as it said it would erase all the data on the drive. The light is also flashing every few seconds on the hard drive. I have also tried pluggint into my husbands playstation 3 and it says no data.

Can anyone offer any help to me with this? Would really appreciate it. I really really don't want to lose the photos ...

Dulchie Registered User
#2

A number of things to try.

If possible try the drive on another computer.

2. Switch off your computer, plug it out or if a portable switch off and remove battery for a few minutes.
3 reconnect the hard drive boot and try again.
4 You might try http://forums.cnet.com/7723-7590_102-323405.html

ricman Registered User
#3

chkdisk can take an hour or more to check the drive,see here,
http://www.techspot.com/vb/topic34363.html
its possible the mbr may be damaged ,so drive looks like its unformatted.
go to control panel,disk management,what does it say,eg 80gig fat 32 drive.

ArtyM Registered User
#4

I think you have to run the "chkdsk g: /r/f" from an admin command prompt in Vista Win 7. Hopefully that will fix your problem as otherwise it may be a damaged partition.
Start>programs>accessories> find command prompt and right-click on it and choose run as administrator. Then type in the chkdsk command above (without the quotes).
Post back with the results.
Good Luck

ricman Registered User
#5

go to control panel,admin tools,computer management, storage, click on drive e, external drive.could be drive f,g etc

ricman Registered User
#6
Milliehollie Registered User
#7

Thanks everyone for the help but need urgent help now,

I am just in the command prompt and I've typed in the chkdsk. it is saying something about "Fat32.
Window is veryfying files & folders...
Files & folders veryification are complete.
Convert lost chains to files? Y/N"

Please help??

Do I say yes or no to this. Don't want to lose any of my photos if I say yest. Will I lose them if I say yes to this?

Maybe I should just quit and bring hard drive to someone

ricman Registered User
#8

say y yes,checkdsk will not delete your disk ,or delete your files ,once its started it let it finish, it can take 1 hour or more ,depending on disk size,no of files.it just cleans up the disk, gets rid of temp files.it will not delete your dpictures,or mp3 s or data files.
when its finished ,it ,ll say 100 per cent complete,click,exit, ok, or esc key, it gives 3, 9, 20 per cent complete ,as it goes along.

ArtyM Registered User
#9

Hey
Might be easier for you if you try a data recovery software like this one:
http://download.cnet.com/Easeus-Data-Recovery-Wizard-Free-Edition/3000-2248_4-75184619.html
It should be able to recover your files and wont ask you these scary questions.

As for the checkdsk, Just click on the x and close the command prompt window that is running the chkdsk.
Good luck

ricman Registered User
#10

its best to exit, leave drive ,on, connected, after its complete,click,start,menu, reboot, restart pc, or turn off pc.
then restart pc.
press esc key,if it trys to check drive again after pc, reboots..

ricman Registered User
#11

click y,yes, convert files to chains, that means it converts temp,files, into proper files , theres no risk to that option. sorry just reread your post,chkdsk is complete, it may take a few minutes to convert files, maybe ten mins or less.this process wil not delete your pics or files,or any data, folders.

ricman Registered User
#12

if you cant see your files, or pictures use this,http://findandmount.com/
a partition is a space on a drive set a side by windows to contain files,in fat32 or ntfs disk format, most external drives have just 1 partition setup in the factory.
it fixes the drive if the mbr is missing or deleted, which makes the drive appear
unformatted.

Milliehollie Registered User
#13

Thanks for advise everyone.

I said no to the chains and it was doing something. I panicked and escaped outof it at 15%.

I just tried the "findandmount.com" and after I downloaded it and plugged in hard drive I got the following message. -
"There is no disk in the drive. Please insert a disk into drive \Device\Harddisk1\dr1"

Couldn't get anywhere with it. Or am I doing something wrong with it?

Dulchie Registered User
#14

You may have caused further trouble by aborting chkdsk. You were 90% of the way there!
I would retry chkdsk and see if it completes successfully.

I am not keen on trying any other program or utility until chkdsk has completed a full run through.

Milliehollie Registered User
#15

Really fed up at this stage.

Tried doing the chkdsk again and said yes to the convert lost chains to files but it now says
"Insufficent disk space to recover lost data
63295648 KB in19099 recovered files
Windows is verifying free space...
0 percent completed..."

There is also a horrible clicking noise now coming from the hard drive
Don't know what to think now

Want to share your thoughts?

Login here to discuss!