#1

Was wondering if anyone could tell me how to change my default DVD player to the VLC player.
I already have it as default for every other video I play, just can't seem to get it to work as the default when I put DVDs in.

Any help would be appreciated.

Thanks.

#3

I already have it set as my default player, but it's just when I put in a DVD Windows Media Player opens up.

There must be some setting to change how my default DVD player.

Can't even change it in my control panel, from what I can see.

http://i34.tinypic.com/2j5nzu0.jpg

Biggins Banned
#4

What version of operating system do you have?

Generally its one of the two following methods:

Step 1. Right click on the media file, and select Open With>Choose Program... Find VLC, and check "Always use the selected program to open this kind of file." Repeat for different extensions.

Step 2. Open windows explorer (like clicking on My Computer). Go Tools> Folder Options. Cick the View File Types tab. Go through this and whenever you see a filetype you want to change, select it, and click Change next to Opens With:. Select VLC. Repeat for different extensions.

...Making sure you add VOB/IFO/BUP file extensions

kierank01 Registered User
#5

You can set the auto start by right clicking on the drive, and selecting properties.

You can change the action that occurs when a particular type of disc is inserted

jpl888 Registered User
#6

Urm would removing Windows Media Player do the trick or is that not possible?

#7

Sorry Biggins, I'm just not as in the know about computers as you are.
I am but a simple keyboard warrior.

I'm using the disaster that is Vista.
When I right click on a DVD it doesn't allow me to choose a default program though.
http://i38.tinypic.com/20t0wbb.jpg

I don't want to remove Windows Media Player as I like having it there for burning CDs and playing music.

Biggins Banned
#8

On the pic you supplied, see sixth one down "Open Autoplay"
Select that.
A box will open on screen. Find the one that references your cd/dvd drive and/or video playing ability.
Select VCL in those options.

For example:




By the way, you could also try uninstalling VCL - then re-installing it (check on the net for the latest version "1.1.2"), selecting it as the principle player in the new set-up for default devices during the re-install!

That might work too.

#9

It's just that VLC doesn't appear in that list for me.

http://i34.tinypic.com/2j5nzu0.jpg

I appreciate the help, I don't think it's going to happen for me though.

Biggins Banned
#10

Have you tried the re-install?

themadhair Registered User
#11

You have to edit the registry to sort this one.

The value that needs to be edited is found at HKEY_CLASSES_ROOT -> DVD -> Shell -> Play -> Command

The value you need can be copied from HKEY_CLASSES_ROOT -> DVD -> Shell -> PlayWithVLC -> Command

Want to share your thoughts?

Login here to discuss!