adrian522 Moderator
#1

Hi,

Could people report any issues they are having with the Desire in this thread as I don't see another similar .thread

I've been having 2 main problems with the desire, both minor as there are workarounds but if anyone has a solution I'd be all ears.

1. The Music Player.

Every so often when I try to play audio files (mp3's) the player will skip each song and display the message "unable to play this type of audio file".

A simple reboot will sort out this problem but it is pretty annoying. Any ideas on possible causes? Possibly a problem with the SD card or something.

2. Wifi Connection

This may be more to do with the WiFi setup at home but I find that the Wifi will drop quite often and I wont be able to load any webpages or look at apps that require data, to fix I need to disable Wifi and then re-enable and it all works ok. Again I've no idea what is causing this but I feel it shouldn't be happening as I don't have the same problems with the laptop, at least not to the same extent. Any ideas welcome.

djgaillimh Registered User
#2

1. What files, specifically? Are they definitely in MP3 format? Are they copy protected? Never seen this on mine.

2. That sounds like an issue with your home wifi. I've got wifi running almost constantly on mine and I've never once seen a drop out, even when the signal is low I can still connect perfectly. I couldn't tell you how to fix it though... maybe somebody else will know.

youcancallmeal Registered User
#3

- Side button snooze does not work or only works some of the time.
- No option to hide SIM contacts from dialer.
- Calls are often accidentally hung up on/answered when taking the phone out of your pocket

And the biggest one of all for me, no way to set the length of time the notification light flashes for. Its 5 mins by default, WTF is that about!? I think there are apps out there to change this but what a silly thing to leave out!

adrian522 Moderator
#4

djgaillimh said:
1. What files, specifically? Are they definitely in MP3 format? Are they copy protected? Never seen this on mine.

2. That sounds like an issue with your home wifi. I've got wifi running almost constantly on mine and I've never once seen a drop out, even when the signal is low I can still connect perfectly. I couldn't tell you how to fix it though... maybe somebody else will know.


Yeah, just normal non copy protected mp3's

for 2 there's an app called wfi fixer that does seem to help but I do still get dropped connections sometimes.

djgaillimh Registered User
#5

Are there specific MP3s that trigger it or is it random?

I'm just trying to work out if this is due to bad encoding or a dodgy SD card...

edit: also, is your phone rooted, and if so were these issues occurring before you rooted?

Keith186 Registered User
#6

adrian522 said:

1. The Music Player.

Every so often when I try to play audio files (mp3's) the player will skip each song and display the message "unable to play this type of audio file".

A simple reboot will sort out this problem but it is pretty annoying. Any ideas on possible causes? Possibly a problem with the SD card or something.

2. Wifi Connection

This may be more to do with the WiFi setup at home but I find that the Wifi will drop quite often and I wont be able to load any webpages or look at apps that require data, to fix I need to disable Wifi and then re-enable and it all works ok. Again I've no idea what is causing this but I feel it shouldn't be happening as I don't have the same problems with the laptop, at least not to the same extent. Any ideas welcome.


I have the exact same problems too.
Only happened with one album, normal 320 kbps files.
Worth noting that I tried to put this on my missus' ipod but it wouldn't add to the itunes library, didn't give an error message just wouldn't work and never played on my phone so I just replaced the mp3s from other source, works fine now.

My WiFi stops working if left connected and left idle. If I'm using it regularly it never stops working. No WiFi issues with anything else in the house just the desire.
I think it is assigned or leases an IP address for an hour or so from the router and when you stop using it and try again after more than an hour it won't work.
Turning off/on WiFi fixes it straight away so I think its something got to do with that.
I'm not up to scratch on networking by any means so if anyone else could let us know if that's even a possible problem I'm all ears!
Any solutions welcome.

EDIT: My phone isn't rooted and I've only had that problem with one particular album.

adrian522 Moderator
#7

djgaillimh said:
Are there specific MP3s that trigger it or is it random?

I'm just trying to work out if this is due to bad encoding or a dodgy SD card...

edit: also, is your phone rooted, and if so were these issues occurring before you rooted?


Hi, phone is rooted, but the same issue was present before. Dodgy SD card most likely explanation, music was working fine today.

Once the issue occurs its all mp3's, reboot the phone and they are all fine...

EDIT: Just going to format the SD card and see if the issue crops up again....

adrian522 Moderator
#8

Keith186 said:

My WiFi stops working if left connected and left idle. If I'm using it regularly it never stops working. No WiFi issues with anything else in the house just the desire.
I think it is assigned or leases an IP address for an hour or so from the router and when you stop using it and try again after more than an hour it won't work.
Turning off/on WiFi fixes it straight away so I think its something got to do with that.
I'm not up to scratch on networking by any means so if anyone else could let us know if that's even a possible problem I'm all ears!
Any solutions welcome.


That could be the same problem as me alright. Also I've noticed that for my home wifi network I've got to set a static IP otherwise I cant even connect to the network. Though I do have a strange wifi network setup at home. not a huge issue anyway.

gubby Registered User
#9

ok I only just got my phone so still trying to find my way around it. I cant seem to connect it to computer.. just message comes up on laptop telling me its safe to unplug device.
anyone know how to make it ring longer.. it only rings once.
there are a few other things that I may bother you with later

Keith186 Registered User
#10

anyone know how to make it ring longer.. it only rings once.


Check out the sticky, has plenty of beginner info...

thegom145 Registered User
#11

Keith186, have you tried increasing the lease time in your routers settings or forcing your router to assign the desire a static IP address?

I haven't had any of these problems with mine, tried it on several wireless networks so far and its been fine.

Want to share your thoughts?

Login here to discuss!