Hootie Registered User
#1

When the burner starts no kersone seems to be coming out the nozzel. We let the tank run dry accidently and I cleaned out the fuel lines but I now think the fuel pump is blocked. I am getting kerosene to the pump but when i disconnect the capillary line coming out of the pump to the nozzel there is nothing coming out, the capillary line itself is clear. Took the pump apart to try and clean but no joy. I may need to replace the pump and have 2 questions - how much is a pump, its a danfoss pump for bentone burner, and how easy is it to replace. Any other suggestions welcomed as house is cold !!!!!!

#2

At the tank is a filter so no dirt should get through to the pump in the first place to block it.

Usually when oil runs out you get an air lock in the pump, thats all,

You need to start the burner and open the bleed screw on the pump and wait unitl oil comes through with air bubbles forming around the bleed screw.
Failing that, you wait for gravity to take its course until there is sufficient back pressure from a tank of oil to force it through to the pump.

Hootie Registered User
#3

I opened both bleed valves on the front and back of pump, there is good pressure coming out of both and saw air bubbles but can't seem to get the oil through. I have tried to restart the burner countless times now but still not working. There is also a good amount of oil in the tank to force downward pressure.

Hootie Registered User
#4

i tried again when i got home, i restarted the burner and opened the bleed valve until oil is coming out. Repeated this many times but still no oil is entering the capillary line. Can anybody give advice please?

Pete67 Registered User
#5

A few suggestions - did you disturb the pressure regulator adjusting screw while trying to bleed the pump? Could it be backed off completely so that the pump is not generating any pressure?

Is there a filter in the oil line, because if not, dirt could get into the pump and block the nozzle.

I'd suggest checking the oil pressure with a suitable guage, should be around 100psi. If OK, change the nozzle. If you are getting all the air out of the line, then the burner should fire.

You can get the Danfoss data sheet for oil pumps under Burner Components here

El Camino Registered User
#6

Hi guys,

I'm having a similar problem myself. The burner kept seizing up after 20 minutes or so and the lock out light would come on. Had a guy out to look at it and he replaced the jet, which seemed to do the trick for a week but now its not firing at all.

When switched on there's not a peep out of it. for a few seconds. When the lock out button is switched on it humms and then stops. Its not firing at all.

The tank did run dry a few weeks ago but there's plenty in there now and the air has been bled out already.

The service guy has suggested that it's knackered and that i need a new burner. He's suggesting that it could be any number of problems and i'd be as well off to just shell out for a new one. i think that's a lazy answer and he may just be looking to make some cash out of this.

Any ideas what i could do myself to rectify this problem? I'd appreciate any suggestions... any at all.

Thanks in advance

c ashelmore Registered User
#7

Is the motor actually turning or just humming? Possible causes- seized pump,seized bearings ,capacitor faulty,jammed fan

Want to share your thoughts?

Login here to discuss!