Goose81 Registered User
#1

Ok,so I posted this in the Vodafone forum for users experiencing issues,on how to remove the rubbish vodafone software and replace it with the stock HTC ROM.(I have had no issues with this phone and I removed the vodafone software straight off the bat)


Im gona post it here because I suspect it will just be deleted in the Vodafone forum:

Lads I know this is the Vodafone forum,but the software they put on the phone ruins it.Remove it and put on the HTC ROM like it was supposed to have before Vodafone butchered it.
I did this before I even used it for the first time and have had not 1 problem with it.Also use HTC's email application,not the android one,its alot better.
Its so easy.
Instructions below:

http://forum.xda-developers.com/showthread.php?t=603286

and a video of the same process on a hero,do the exact same thing as the video shows except use the Tattoo rom from above link.

http://theunlockr.com/2009/10/18/how-to-downgrade-your-htc-hero-so-it-can-be-rooted/

You are better off following the video exactly and using the HTC software from the top link.Thats what I did and after you do this you can just install the new updates when HTC release them without having to rely on Vodafone updates.
(I used thesd card that came with mine to do above process)

1 person has thanked this post
#2

Does this method no longer work? I tried on 3 different pc's and can't get the "adb shell cat /sys/class/mmc_host/mmc1/mmc1:*/cid" command to work, keeps saying device not found


C:\Users\Colm>cd c:\androidtools\tools

c:\androidtools\tools>adb shell cat /sys/class/mmc_host/mmc1/mmc1:*/cid
error: device not found

c:\androidtools\tools>


finhex Registered User
#3

PogMoThoin said:
Does this method no longer work? I tried on 3 different pc's and can't get the "adb shell cat /sys/class/mmc_host/mmc1/mmc1:*/cid" command to work, keeps saying device not found

You need to connect Tattoo with PC using HTC Sync option (not USB drive) to get this command to work.

#4

Ok, got as far as updating the phone, every time I try it gives this error. I've gone through all the steps twice. I even downloaded and tried an older version of the official HTC rom but same. Any ideas?



Edit: Did You replace the first 2 digits in the reverse string with 00 like in the vid?
Edit2, don't matter, mine already start with 00

Attachments
Capture.JPG
finhex Registered User
#5

I don't havwe any idea what could be wrong... Are you sure that your phone is started as fastboot mode?

Ludo Registered User
#6

What are the advantages of doing this? I have the tattoo and it is fine the way it is so just wondering what I am missing by not having done this?

finhex Registered User
#7

I did this upgrade just to get latest version of the operating system.

#8

Yep, it means You can update to the latest HTC version, not 3 months+ later when Vodafone decide to release their update

Got into Hboot, I had usb fastboot enabled, the phone rebooted, started to erase data and then threw up this error. I'm gonna try again this eve without going through a usb hub
Could also be a Windows 7 issue, I'll try on xp later

Want to share your thoughts?

Login here to discuss!