fitzet Registered User
#1

Hi, I have an original Lego Mindstorms RIS 1.0 from years ago and my son just took it out to see if we could make it work again. It has an RS232 serial connector for the IR unit (no USB) and the software doesn't seem to work very well with Windows XP. Just wondering if anyone knows if the IR unit will work with a USB/serial adaptor and if there is anywhere I can get an upgrade for the software so it can work on XP? Or is there another cost effective way to get my son going on mindstorms 1.0 without the investment it would take to buy the new Mindstorms NXT?

Landoflemon Registered User
#2

Hi there,

I'm a mechanical engineering student. I also had the same problem years ago, I fried the psu on my old computer at home. My parents got a new one, and then I realized that there was no serial port for the IR transmitter. I went and bought a USB/Serial adapter, but the IR tower, after doing much research will not work with the adapter, It just is not recognised.

There are 2 solutions:

You could find someone who is selling (or often giving away) an ancient PC that has a serial connection and use that...

Or do what I did and upgrade to the very expensive NXT set. I had spent a lot of money on the original Robotics Invention System (I had 3 sets of it) and it's very annoying that the motors and sensors and the 3 RCX's are going to waste. At least all the rest of the parts can be used with the NXT....

fitzet Registered User
#3

Hi thanks for your reply.

Believe it or not I got it working! I'm posting the details here in case it is of use to anyone else.

I got a USB 1.0,1.1,2.0 to Serial RS232 DB9 com port cable on Ebay (this is the link
http://cgi.ebay.ie/ws/eBayISAPI.dll?ViewItem&item=360126812748&ssPageName=STRK:MEWNX:IT).

The drivers it came with didn't work so I had to spend a LOT of time online before I found one that did. I think it was this site: http://www.soft32.com/Download/Free/Bafo_Technology__USB_to_DB9_Serial_Adapter_BF810/4-170532-1.html.

Then I had to find a 2.0 version of the RIS software so it would work with XP. Lego did issue a cd with a 1.5 and 2.0 update software years ago but it doesn't seem to be available any more (Lego support never answered my queries about getting one) so I 'acquired' a version online.

Then I had to set the software to run in windows 98 compatibility mode. (right click the icon, properties, compatibility and select windows 98). (With hindsight I might have got my 1.0 software working this way too.)

After all that I had to set Quicktime to be version 6.5.2 as the RIS 2.0 software was giving me Quicktime errors at startup and I got that from http://www.oldversion.com/download_QuickTime_6.5.2.html.

Now my Itunes isn't working because it doesn't like the old Quicktime so I will probably put all that stuff in a separate account just for Mindstorms.

It took a couple of days to get it all the bits in place but I didn't want to have to upgrade to the NXT without knowing whether my son was going to get properly involved with it. All it cost me was the price of the cable and I did get a great sense of achievement at the end of it!!

Hope this helps you if you decide to have another go at it.

Landoflemon Registered User
#4

This is an interesting development, I'm going to send you a private mail.

raybarclay Registered User
#5

Hi,

I have the same problem. Bought for my elder son years ago but now the younger one has come of age for it, but I cannot find the original cable. Using the USB port makes a lot of sense. I tried the driver download link but it was broken. Any chance of passing me the files privately or uploading them somewhere please?

fitzet Registered User
#6

This is actually the link with the driver that worked for me. http://www.cooldrives.com/wividrforprc.html. I went through so many I wasn't sure which was the right one! I just checked the link and it still seems to be working ok.

If you need any other info just let me know.

raybarclay Registered User
#7

Thanks, that one downloaded. Haven't ordered the cable yet but it looks like it is a male connector instead of a female one and might be too wide/short to fit in the deep socket - so can I just check that you didn't do any other mods to get it to work and that unlike all those other cables out there this one has a female connector.

pickarooney Moderator
#8

Is a PCI-slot COM port not an option? It would avoid the need for messing with drivers, unless you're using a latop of course.

raybarclay Registered User
#9

I expect adding a COM port would work. The advantage of the USB cable approach is that you can go anywhere with a laptop, which adds to the fun. I'm lucky that I still have a laptop with an appropriate socket, but unlucky in that the cable has gone awol and the slot on the transmitter is such an odd shape that it is hard to get an adaptor to fit. I expect extending the original cable is how fitzet did it but it would be nice to have that confirmed.

fitzet Registered User
#10

Yes I still have the original cable and the new one just plugged into that (on my laptop). I did also download the RIS 2.0 software and ran that in windows 98 compatibility mode and got the older version of Quicktime also (all in my original post), but that was basically it – nothing more technical than that. This was to get it to work on my laptop which still has XP. Don’t know if you’d have to do anything else to get it to work with Vista or Windows 7.

dannystaple Registered User
#11

While the RIS default software is quite nice, in that it gives you presentations and a simple programming language, it is not the only way to get the RCX programmed.

The contructopedia parts on it can be found freely on the internet with a bit of looking, along with many other great RCX based models.

Languages or systems like Lejos, NQC (Not Quite C) and BricXcc offer alternative means for programming the RCX, which are more sophisticated than the bundled offering.

You can find out about NQC at http://www.squidoo.com/collected-info-on-the-lego-rcx#module79322281.

Cheers,
Danny

hockey246 Registered User
#12

I also have RIS 1.0, and I've tried the 95 compatibility mode under Vista, but when I try to run it, it just says "loading..." and nothing happens. Is this the Quicktime issue? I downgraded to the old version of Quicktime and I get the same problem. I've also tried it on a windows2000 machine and I get the same thing. Has anybody seen this error? Also, where did you download 2.0 from?

Ededvem Registered User
#13

Can u tell me where you got the RIS 2.0 version?

Want to share your thoughts?

Login here to discuss!