Redriddick Registered User
#1

Hi guys,
As the title says im having problems with my citroen berlingo van.I have no wipers and the washer does not work.Now i have taken off the cowels from around the steering wheel and when i disconect the grey plug from the back of the switch unit the wiper will work on its own.I guess im trying to narrow down the search for the problem.Any help would be great.
Thanks
Redriddick

niceirishfella Registered User
#2

Redriddick said:
Hi guys,
As the title says im having problems with my citroen berlingo van.I have no wipers and the washer does not work.Now i have taken off the cowels from around the steering wheel and when i disconect the grey plug from the back of the switch unit the wiper will work on its own.I guess im trying to narrow down the search for the problem.Any help would be great.
Thanks
Redriddick


an auto electrician is your best bet here Red, sorry.

Hal1 Registered User
#3

Redriddick said:
Hi guys,
As the title says im having problems with my citroen berlingo van.I have no wipers and the washer does not work.Now i have taken off the cowels from around the steering wheel and when i disconect the grey plug from the back of the switch unit the wiper will work on its own.I guess im trying to narrow down the search for the problem.Any help would be great.
Thanks
Redriddick


You did what, try the easier option first and check the fuses. Do you hear anything from the wiper motor when its engaged?

niceirishfella Registered User
#4

Hal1 said:
You did what, try the easier option first and check the fuses. Do you hear anything from the wiper motor when its engaged?


+1. i assumed you checked the fuses yeah op?
if you did, and they are ok, then before you go ripping anymore stuff etc apart, talk to an auto electrician.

Redriddick Registered User
#5

niceirishfella said:
+1. i assumed you checked the fuses yeah op?
if you did, and they are ok, then before you go ripping anymore stuff etc apart, talk to an auto electrician.


Hi guys,
Thanks for the replies.I have checked all fuses and all are ok.I know that the comm2000 units i.e the indicator and wiper/washer stalks are notorius for giving bother on citroen and peugeot so i think i may have to ring a citroen garage to get advice.Thanks again guys and other ideas welcome.

Regards Redriddick

crosstownk Registered User
#6

I'd also be inclined to suspect the comm2000. As you say, it's a common enough fault.

Redriddick Registered User
#7

crosstownk said:
I'd also be inclined to suspect the comm2000. As you say, it's a common enough fault.


Thanks crosstown i read somewhere about a comm2000 reset but cant seem to find it.Hate to get one and then realise that its the bsi unit

crosstownk Registered User
#8

Redriddick said:
Thanks crosstown i read somewhere about a comm2000 reset but cant seem to find it.Hate to get one and then realise that its the bsi unit


The link below may help.....

http://www.citroenpicasso.org.uk/picasso/index.php?act=ST&f=9&t=14716

lifer_sean Registered User
#9

Redriddick said:
Hi guys,
Thanks for the replies.I have checked all fuses and all are ok.I know that the comm2000 units i.e the indicator and wiper/washer stalks are notorius for giving bother on citroen and peugeot so i think i may have to ring a citroen garage to get advice.Thanks again guys and other ideas welcome.

Regards Redriddick


Replaced one on a Partner recently. Main dealer 250 euro plus vat. Ordered a s/h one from BridgeVan in Co Derry at 11.30am and had it at 8.30am the next morning. 60 stg +vat for the part, 20 stg for the delivery.

If you do need to get one be careful because there are different ones and not interchangable, eg does your van have rear wipers ?

Redriddick Registered User
#10

lifer_sean said:
Replaced one on a Partner recently. Main dealer 250 euro plus vat. Ordered a s/h one from BridgeVan in Co Derry at 11.30am and had it at 8.30am the next morning. 60 stg +vat for the part, 20 stg for the delivery.

If you do need to get one be careful because there are different ones and not interchangable, eg does your van have rear wipers ?


Hi guys,

Glad to report back that i did the comm reset and low and behold everything working again.Just think as lifer sean said i could have forked out 250 euro or 80 pound sterling for it.Again boards and its members come to the rescue.Thanks very much guys.

2 people have thanked this post
niceirishfella Registered User
#11

As Hannibal always said, i love it when a plan.........................

v33jmc Registered User
#12

lifer_sean said:
Replaced one on a Partner recently. Main dealer 250 euro plus vat. Ordered a s/h one from BridgeVan in Co Derry at 11.30am and had it at 8.30am the next morning. 60 stg +vat for the part, 20 stg for the delivery.

If you do need to get one be careful because there are different ones and not interchangable, eg does your van have rear wipers ?


hi just seen ur reply am ,from co.derry,i have a problem with my wipers ther not turnin off right they keep goin at intervals,wonder if u can help?thanks james

kincaid Registered User
#13

i got a problem with my 03 berlingo too, wipers will not work at all, dash clock works for a while on starting then everything disappears completely of it no symbols, speedo etc, headlights work and then do not...

Row Registered User
#14

kincaid said:
i got a problem with my 03 berlingo too, wipers will not work at all, dash clock works for a while on starting then everything disappears completely of it no symbols, speedo etc, headlights work and then do not...


Like above it sounds like a faulty coms 2000 unit or theres a problem with the bsi which controls wipers..lights..etc.

If the water drain points block up in and around the bulkhead water can build
up and run down the inside and inturn into the bsi unit....maybe worth checking.

supa_stench Registered User
#15

I have the opposite problem with my citroen berlingo. My wipers seem to be stuck in intermittent mode even though the stalk thing is in the off position.

I'm driving around praying for rain........

If I replace this comms 2000 box will it solve my problem?

Also the radio has a mind of it's own, it turns itself on and off whenever it likes even if the engine is turned off! Will a new comms box fix this too???

Thanks in advance,


John.

Want to share your thoughts?

Login here to discuss!