steadyeddie08 Registered User
#1

Latop is an Advent 7109.

When you connect the ac adapter the screen is getting brighter so this means the laptop knows that it is connected. However it is not charging the battery.

Have charged the battery in another laptop without any problems and using the same ac adapter so I do not think there is a fault with either the battery or ac adapter.

Any ideas???

meep Registered User
#2

Same thing happened me a couple of months back, (Advent or Acer or something like that). Returned it under warranty. Motherboard replaced. Went through one charge cycle and it happend again. Brought it back to shop and they binned it and gave me the choice of another laptop to similar value (as things had moved on about 9 months, I got a much better spec. machine as well).

You under warranty?

kikel Awaiting Email Confirmation
#3

A problem with the DC socket i'd say. The connection inside the laptop. Weird though that the screen get brighter.

Soundman Registered User
#4

One quick solution you can try is:

*Turn Laptop off
*Remove AC Power
*Remove Battery
*Press and hold Power button for 30 seconds
*Leave for 2 minutes
*Put battery back in
*Put AC Power back in

After this you should be able to see if the battery is charging if you have a battery light. Power on and see what the Power Options icon in your Taskbar has to say.

Worked for me about 3 weeks ago when my battery suddenly said that it didn't want to charge.

steadyeddie08 Registered User
#5

Laptop is out of warranty.

Tried your solution Soundman but no joy. Will have to take it apart and check the DC socket in the next few weeks.

Thanks

Want to share your thoughts?

Login here to discuss!