mxe01 Registered User
#1

Hi,

Can anyone help - I have a Grant Minor One S burner which has been playing up recently. Started with the oil pump developing a leak (Suntec As47A) Around the same time, the motor would intermittantly 'stick'

Decided to change the motor and pump and drive coupling. (all genuine parts) but now, no oil comes out from the pump. It points to the solenoid valve not operating, but I can hear it clicking after 10sec, but nothing.

I've swapped the control box and put a new photocell in but still no oil. If I remove the solenoid piston, I get oil.

I would say that this definately points to the solenoid valve but I swopped the pump (which incorpoates the solenoid) back to the old one and no oil comes through that one either.

I've run out of ideas

Any help or pointers would be much appreciated

Thanks

JamesM Registered User
#2

I presume that you have bled the pump. Have you loosened the nut on the pipe to the nozzle to see if it's not just a blocked nozzle ? Have you put the motor, pump and drive coupling back together properly ? Did you fit a new solenoid coil ? They often give trouble.
Jim.

mxe01 Registered User
#3

Jim,

Thanks for your reply,

If I remove the solenoid valve, it'll pump oil OK. That tells me that the pump is properly connected to the motor and is pumping oil OK.

I've removed the pipe from the outlet of the pump and I get no oil there.

It was a new coil that came with the pump - I've also fitted the old coil and that doesn't make a difference.

It's totally baffled me - it seems a long shot that the new pump/solenoid/coil are faulty along with the old ones which were working OK but just had a persistant drip from the bearing seal.

Again, if anyone has any ideas, I'd really appreciate it

Many thanks

Mike

JamesM Registered User
#4

Have you changed the oil pressure adjustment screw ? If you have changed the settings, Screw it in fully and then turn anticlockwise about 5 turns
Is the new pump the same make or did you get a Danfoss pump ? Are you sure that you have connected to the correct outlet ?

I don't want to rub this in, but you are already well on the way to the price of a new burner. For anyone else that still has a Minor 1, if it gives trouble, scrap it and buy a new burner - they gave a lot of trouble. Grant stopped using them in about '92 or '93.
Jim.

mxe01 Registered User
#5

Jim,

Thanks again for the reply,

I can certainly agree that this burner has been troublesome over the years. I installed it new in 1994ish and it's given nothing but trouble ever since.

I've changed like for like, Suntec pump/solenoid/coil/ for exactly the same

Simel motor - again like for like

It doesn't make sense.

Although I've changed a good few parts, cost wise, it's been very cheap to resource the parts - however, it's cost me hours of time on my knees in the shed on my own. I think I would certainly have to agree that in the long run, I would have been better off changing the burner complete.

Best regards

Mike

JamesM Registered User
#6

It really does seem like the solenoid. Do you think that it is the solenoid clicking after 10 secs, or is the sound coming from the control box ? If the solenoid is not clicking, check that you have not pulled out one of the solenoid coil wires in the control box base.
Have you 1 or 2 oil lines going into the oil pump. There is a screw supplied with the pump, which needs to be either put in or left out depending whether you have a 1 or 2 pipe system. You will see something about it in the pump instructions.
I really can't think of anything else
Jim.

mxe01 Registered User
#7

Just an update,

Problem eventually sorted - bought another Suntec pump locally (cost me an arm and a leg) after I was convinced that the new pump I fitted had a faulty solenoid valve and the burner fired up immediately. Only conclusion that I could draw was that the valve was indeed faulty.

Just need a refund on the other one and I'll be a happy man.

Jim, thanks for all your replies

Regards

Mike

JamesM Registered User
#8

Very frustrating when the "new" part is faulty
Glad you got it sorted
Jim.

Lex Luthor Registered User
#9

JamesM said:

I don't want to rub this in, but you are already well on the way to the price of a new burner. For anyone else that still has a Minor 1, if it gives trouble, scrap it and buy a new burner - they gave a lot of trouble. Grant stopped using them in about '92 or '93.
Jim.


Hi Jim,

I have a Minor 1 that has been running fine for teh last 6-7 yrs but gave a bit of trouble in the first 3-4yrs.

Its in 12 yrs now and I'm happy with that. What would you suggest replacing them with if it eventually did pack in?

JamesM Registered User
#10

Lex Luthor said:
Hi Jim,

I have a Minor 1 that has been running fine for teh last 6-7 yrs but gave a bit of trouble in the first 3-4yrs.

Its in 12 yrs now and I'm happy with that. What would you suggest replacing them with if it eventually did pack in?


The problems with the Minor 1 were usually mechanical. The combustion side of things was usually good. They are quite efficient. If it is running OK, I would leave it alone - it is not wasting oil like some of the older models.
When the time comes to replace it, If you are using diesel, I would use the Riello G3. If you have kerosene, either the G3 or Riello RDB. A Bentone would also be OK with kerosene - not as good with diesel.
Jim.

GatsbyDub Registered User
#11

Anyone know how to access the electrodes. I removed the burner from the boiler. How do I get the metal cylinder out to access the nozzle and electrodes.

Any help would be appreciated

GatsbyDub

JamesM Registered User
#12

GatsbyDub said:
Anyone know how to access the electrodes. I removed the burner from the boiler. How do I get the metal cylinder out to access the nozzle and electrodes.

Any help would be appreciated

GatsbyDub


With the Minor 1 there is one, or sometimes two, allen screws in the body holding the head in place. Small holes in the casing at the top. If you think that there is no spark, move the electrodes closer together, the transformer often fails in these, but you can sometimes get a spark by closing the gap. Make sure that the electrodes do not short on the head when you put it back together. Looking at my past posts, remember that a new burner can be cheaper than constantly putting parts into an old one. You can safely chech that the spark is OK by pulling the plug out of the solenoid coil, and looking at the front of the burner - it will not ignite in your face.
Jim.

GatsbyDub Registered User
#13

JamesM said:
With the Minor 1 there is one, or sometimes two, allen screws in the body holding the head in place. Small holes in the casing at the top. If you think that there is no spark, move the electrodes closer together, the transformer often fails in these, but you can sometimes get a spark by closing the gap. Make sure that the electrodes do not short on the head when you put it back together. Looking at my past posts, remember that a new burner can be cheaper than constantly putting parts into an old one. You can safely chech that the spark is OK by pulling the plug out of the solenoid coil, and looking at the front of the burner - it will not ignite in your face.
Jim.


Are you there, Jim?

GatsbyDub.

GatsbyDub Registered User
#14

GatsbyDub said:
Are you there, Jim?

GatsbyDub.


Don't you get about 20 seconds of the electrodes sparking before the kerosene comes out? Wouldn't that be enough time to see if the electrodes are sparking?

GatsbyDub

Traditional Registered User
#15

are the electrodes sparking ?
will it not start ?

Want to share your thoughts?

Login here to discuss!