Boards.ie uses cookies. By continuing to browse this site you are agreeing to our use of cookies. Click here to find out more x
Post Reply  
 
 
Thread Tools Search this Thread
16-01-2012, 12:48   #1
snyperkyller
Registered User
 
Join Date: Jun 2009
Posts: 26
how can I fix my leaking electric shower? (triton)

Hi, for months now there's been a leak coming from inside my Triton T90xr shower. I turned off the electricity and opened it up and can see exactly where the leak is coming from - between the parts that are joined with screws. Please see photo attached. You can actually see a big drip about to fall.

Any ideas on how to fix this? The screws to get the part off are in awkward places. It looks like I'd nearly have to dismantle the whole unit to get it off. I twiddled around with it before (the dial part below) and the water was under a lot of pressure and it was hard to squeeze back in. So I guess the smart thing to do would be to drain the tank in the attic first, for less pressure.

One idea I thought of was relieving the pressure by modifying the ball cock in the tank so it would never be full. I'll try that solution, if all else fails.

Thanks for any help. I'd prefer to fix this myself, as stuck for cash at the moment.

Chris.
Attached Images
File Type: jpg phpa4BKEUAM.jpg (138.2 KB, 706 views)
snyperkyller is offline  
Advertisement
16-01-2012, 18:04   #2
Joey the lips
Stealing Hugs Chasing Kisses
 
Joey the lips's Avatar
 
Join Date: Jul 2008
Location: Frankfurts way
Posts: 9,934
You cant. You need to replace that and tbh i would look at your pipework carefully that only goes for 2 reasons

1. Frost

2. Connected to mains.
Joey the lips is offline  
Thanks from:
16-01-2012, 18:10   #3
Billy Bunting
Registered User
 
Billy Bunting's Avatar
 
Join Date: Dec 2007
Location: swany river
Posts: 2,551
It's a pain in the ass but Joey right, you wont get that part without buying the complete motor, very common to crack with frost, try and find someone with an old shower that you might be able to rob.
Billy Bunting is offline  
16-01-2012, 23:04   #4
stoneill
Registered User
 
stoneill's Avatar
 
Join Date: Sep 2009
Location: Dublin
Posts: 2,611
It is possible using a gasket seal, but it does mean stripping down the shower unit.
If it the seal between the motor pump and impeller is gone then you can try that.
If any of the plastic mouldings are cracked then I'm afraid it will need that part.

(make sure to turn off power and turn off water before any repair work!)
stoneill is offline  
17-01-2012, 09:54   #5
looksee
Moderator
 
Join Date: Aug 2006
Posts: 8,222
I had this problem with a new Triton shower. Turned out the builder had connected a tank-feed shower to mains pipes. No cure, had to get a new shower.
looksee is offline  
Thanks from:
Advertisement
17-01-2012, 21:10   #6
650gs
Registered User
 
Join Date: Feb 2010
Posts: 581
You should leave this job to a professional, Remember these showers are very dangers if not fitted properly you could be playing with your life
650gs is offline  
17-01-2012, 22:17   #7
paddy147
Banned
 
Join Date: Apr 2009
Posts: 15,390
Quote:
Originally Posted by 650gs View Post
You should leave this job to a professional, Remember these showers are very dangers if not fitted properly you could be playing with your life

As per the tragic accident late last year with the young GAA lad,down the country being electrocuted to death in the shower.
paddy147 is offline  
18-01-2012, 00:08   #8
snyperkyller
Registered User
 
Join Date: Jun 2009
Posts: 26
Hi, thanks for the feed back.

Joey the lips, what's wrong with connecting the shower to the mains? Should electric showers not be connected in that way?

I thought all along it was connected to the tank in the attic but after draining the tank to do some work on the shower I saw water kept coming and coming so I turned off the mains and then it stopped. So it looks like there's a connection to the mains, somewhere off the pipe that leads to the tank.

I took off the shower (electricity and mains off, of course) and dismantled the section in my attached photo. No cracks or anything, and the rubber washer is perfect. Then I tightened up the screws again, but it still leaked when I put it back. Took it off again and put sealant in and re-tightened everything but still leaks, although less now. Really a pain. Thanks again for all your help.

Chris.
snyperkyller is offline  
18-01-2012, 00:17   #9
Kevin Irving
Registered User
 
Join Date: Oct 2004
Location: Dublin
Posts: 2,319
Send a message via MSN to Kevin Irving
You're not allowed pump directly from the mains apparently, even pressure washers use a small tank. To do with contamination I think.

Aside from that, the mains has bits of dirt and stuff it in - just look at the bottom of your attic tank, probably will be a layer of sediment there which, over time, is very bad for the shower.

Unless you know exactly how the shower operates, and you feel 100% confident, and have the experience, don't mess with anything but the filter. Even if the power is off while you're at it, you don't want someone in the shower next week to be to get an 8kW shock.
Kevin Irving is offline  
Advertisement
18-01-2012, 00:47   #10
Merch
Closed Account
 
Join Date: Mar 2009
Posts: 3,246
I was fairly sure this model couldnt be connected to the mains, some other triton models can
http://www.tritonshowers.ie/media/11724/t90xr.pdf
See page 6
Id try confirm for certain that it is connected to the mains, maybe the mains pressure affected the shower/cause the leak.

There should also have been an isolation valve installed between the water supply and the shower.
It sounds like it may have been incorrectly installed, how old is it?
I think I have a part for a T90 si but I would need to look for it, plus not sure if the shape is the same.

If there is a leak and the seal is ok, then there must be a crack in it somewhere,maybe through one of the screw holes?
Merch is offline  
18-01-2012, 00:52   #11
Guy:Incognito
Registered User
 
Guy:Incognito's Avatar
 
Join Date: Feb 2003
Location: Tallaght
Posts: 26,068
Quote:
Originally Posted by snyperkyller View Post
Hi, thanks for the feed back.

Joey the lips, what's wrong with connecting the shower to the mains? Should electric showers not be connected in that way?

I thought all along it was connected to the tank in the attic but after draining the tank to do some work on the shower I saw water kept coming and coming so I turned off the mains and then it stopped. So it looks like there's a connection to the mains, somewhere off the pipe that leads to the tank.

I took off the shower (electricity and mains off, of course) and dismantled the section in my attached photo. No cracks or anything, and the rubber washer is perfect. Then I tightened up the screws again, but it still leaked when I put it back. Took it off again and put sealant in and re-tightened everything but still leaks, although less now. Really a pain. Thanks again for all your help.

Chris.
T90 is a tank fed shower. T80 is for mains.

I think you've found your problem anyway. But replacing the part will be pointless without sorting your pipework.
Guy:Incognito is offline  
18-01-2012, 01:13   #12
Cedrus
Registered User
 
Join Date: Oct 2011
Posts: 1,118
It looks like wrong shower for the water supply, but sometimes it will work depending the local pressure (it did for a while for you).

I had a problem that looked like this (but with right shower for tank), seems the shower unit had become a little loose since it was installed, so the owner opened up the front and tightened the wall fixing screws. Unfortunately the tiles that it was mounted on were not flush, causing a tiny amount of bowing to the back, this was just enough to pop one of the many push fit joints and it started dripping. Solution that day was loosen fixing screw and get a washer in behind the back.

Last edited by Cedrus; 18-01-2012 at 01:21.
Cedrus is offline  
18-01-2012, 09:53   #13
Joey the lips
Stealing Hugs Chasing Kisses
 
Joey the lips's Avatar
 
Join Date: Jul 2008
Location: Frankfurts way
Posts: 9,934
Quote:
Originally Posted by snyperkyller View Post
Hi, thanks for the feed back.

Joey the lips, what's wrong with connecting the shower to the mains? Should electric showers not be connected in that way?

I thought all along it was connected to the tank in the attic but after draining the tank to do some work on the shower I saw water kept coming and coming so I turned off the mains and then it stopped. So it looks like there's a connection to the mains, somewhere off the pipe that leads to the tank.

I took off the shower (electricity and mains off, of course) and dismantled the section in my attached photo. No cracks or anything, and the rubber washer is perfect. Then I tightened up the screws again, but it still leaked when I put it back. Took it off again and put sealant in and re-tightened everything but still leaks, although less now. Really a pain. Thanks again for all your help.

Chris.
A triton t90 is not a mains fed shower and what is wrong is it implodes like the picture you describe if connected to the mains that is whats wrong.

A t80 is a mains fed shower.

Your shower is plumbed incorrecly and tbh your lack of experience and your poor research is very very dangerous combination.

If your going mains you need to get a t80. If your going tank fed you need to get a t90.

You cannot fix your problem you need to dispose of the shower and decide weather you are going mains or tank fed.
Joey the lips is offline  
18-01-2012, 10:19   #14
snyperkyller
Registered User
 
Join Date: Jun 2009
Posts: 26
Hi, thanks for the feedback.

It's definitely connected to the mains, and I see in the online manual it says the T90 should ONLY connect to attic tank (their caps).

JoeytheLips - I actually think my research has been quite good. And about my lack of experience; I'd feel more confident in a professional plumber/ electrician if it hadn't been a person from that trade who'd hooked up the pipes incorrectly in the first place!

Again, thanks for the help; I'll look at connection in the attic and see what needs to be done about taking water from the tank.

Chris.
snyperkyller is offline  
Thanks from:
18-01-2012, 10:51   #15
Joey the lips
Stealing Hugs Chasing Kisses
 
Joey the lips's Avatar
 
Join Date: Jul 2008
Location: Frankfurts way
Posts: 9,934
Quote:
Originally Posted by snyperkyller View Post
Hi, thanks for the feedback.

It's definitely connected to the mains, and I see in the online manual it says the T90 should ONLY connect to attic tank (their caps).

JoeytheLips - I actually think my research has been quite good. And about my lack of experience; I'd feel more confident in a professional plumber/ electrician if it hadn't been a person from that trade who'd hooked up the pipes incorrectly in the first place!

Again, thanks for the help; I'll look at connection in the attic and see what needs to be done about taking water from the tank.

Chris.
You will still need a new shower. If i were you i would look at a t80 which is at least 100 euro cheaper than the t90 and clearly already piped for. then if you are very unfortunate you can add on a cheap single impeller booster pump and divert the mains to the tank so now you have a pumped shower.

Its the least amount of work for you
Joey the lips is offline  
Post Reply

Quick Reply
Message:
Remove Text Formatting
Bold
Italic
Underline

Insert Image
Wrap [QUOTE] tags around selected text
 
Decrease Size
Increase Size
Please sign up or log in to join the discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search



Share Tweet