Zanussi Washer/Dryer problem - boards.ie
Boards.ie uses cookies. By continuing to browse this site you are agreeing to our use of cookies. Click here to find out more x
Post Reply  
 
Thread Tools Search this Thread
13-04-2011, 19:11   #1
timbel
Registered User
 
Join Date: Mar 2006
Location: D15
Posts: 110
Zanussi Washer/Dryer problem

Hi

I have a Zanussi Washer/Dryer (ZWD 14270 W1).
Went to do a wash but no display/lights come on.
Turned knob to off and back on to any wash/dry setting - no display/light.
Checked power/plug fuse - no problems there.

Any ideas?

Thanks.
timbel is offline  
Advertisement
13-04-2011, 19:19   #2
iMax
Banned
 
Join Date: Jul 2004
Posts: 3,432
Sounds like a pcb problem. Give zanussi a call & organise a service. Costs €75 but there's a 5 year warranty on parts.
iMax is offline  
13-04-2011, 21:08   #3
knighted_1
Banned
 
Join Date: Oct 2006
Location: dublin
Posts: 857
check first for a bad connection on the pcb board first in particular the two wires from the supressor at the back/power in attaching to the board -that model have a habit of coming loose -

zanussi charge 75 for a call out but they will charge parts on top of that
knighted_1 is offline  
14-04-2011, 19:06   #4
timbel
Registered User
 
Join Date: Mar 2006
Location: D15
Posts: 110
I opened it up, but there didn't seem to be any loose power connections.
Gave Zanussi a call - waiting from a call from the engineer.

thanks
timbel is offline  
Post Reply

Quick Reply
Message:
Remove Text Formatting
Bold
Italic
Underline

Insert Image
Wrap [QUOTE] tags around selected text
 
Decrease Size
Increase Size
Please sign up or log in to join the discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search



Share Tweet