Boards.ie uses cookies. By continuing to browse this site you are agreeing to our use of cookies. Click here to find out more x
Post Reply  
 
Thread Tools Search this Thread
13-07-2008, 20:04   #1
ollielaroo
Registered User
 
ollielaroo's Avatar
 
Join Date: Aug 2004
Location: Galway
Posts: 70
Miele vaccum cleaner not working

Hi all,

I wonder if anyone can help. My vacuum cleaner has stoppped working and when I plug it in a red warning light comes on (Miele Cat & Dog 700). I don't have the user manual so I don't know what the problem could be and the Miele website doesn't seem to provide any such documents for this model.

I did the usual.... ensured the bag was empty, checked the hose for blockages and put a new 13amp fuse in the plug but stll no joy.
I have attached a picture of this vacuum cleaner if it helps.

Any suggestions would be appreciated. Thank you.
Attached Images
File Type: gif miele_700.GIF (23.7 KB, 100 views)

Last edited by ollielaroo; 13-07-2008 at 20:05. Reason: Spelling
ollielaroo is offline  
Advertisement
13-07-2008, 21:13   #2
byte
Registered User
 
byte's Avatar
 
Join Date: May 2001
Location: Town
Posts: 16,730
Is that a warning light that has an exlamation mark inside a triangle? This usually means the vac has overheated, and needs to be left for 30mins until it cools again.

of course, if the vac hasn't been used in some time, it's not overheating that's the problem, though motor itself could be a suspect.
byte is online now  
18-07-2008, 18:47   #3
OsciiBoscii
Registered User
 
OsciiBoscii's Avatar
 
Join Date: Feb 2008
Posts: 215
Look at www.fixya.com. hope this helps.
OsciiBoscii is offline  
19-07-2008, 11:51   #4
ollielaroo
Registered User
 
ollielaroo's Avatar
 
Join Date: Aug 2004
Location: Galway
Posts: 70

Thanks byte and OsciiBoscii for your comments.

Yes a warning light that has an exlamation mark inside a triangle. It still won't turn on today.
I went to the site www.fixya.com, and it looks like maybe it's something to do with a circuit board for/near the motor that may need to be replaced. It's a damn good vacuum cleaner (but is also out of warranty) so I'll bring it to some repair guy in town and see what he says.

Thanks a lot.
ollielaroo is offline  
20-07-2008, 01:34   #5
byte
Registered User
 
byte's Avatar
 
Join Date: May 2001
Location: Town
Posts: 16,730
Quote:
Originally Posted by ollielaroo View Post
Thanks byte and OsciiBoscii for your comments.

Yes a warning light that has an exlamation mark inside a triangle. It still won't turn on today.
I went to the site www.fixya.com, and it looks like maybe it's something to do with a circuit board for/near the motor that may need to be replaced. It's a damn good vacuum cleaner (but is also out of warranty) so I'll bring it to some repair guy in town and see what he says.

Thanks a lot.
Yeah, Miele vacs are generally very good, so should be worth having somebody look at it.
byte is online now  
Post Reply

Quick Reply
Message:
Remove Text Formatting
Bold
Italic
Underline

Insert Image
Wrap [QUOTE] tags around selected text
 
Decrease Size
Increase Size
Please sign up or log in to join the discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search



Share Tweet