GrumPy Registered User
#1

Just put my 1GB SD card into my pc's card reader, and it gives me an error when I try delete/transfer data - says that it's write protected.


The little "lock" slide thingy on the side of the card is not set on the lock position, so I dont under stand why it wont let me transfer stuff

The file that is on it atm (a powerpoint slide) works perfectly?

Any ideas guys? Windows XP wont let me format it.

BTW: the powerpower slide wont let me edit it, same error of course.

Ruu_Old Closed Account
#2

A few googles suggest putting a piece of tape over the lock, couple of people commented that it worked. Worth a try.

GrumPy Registered User
#3

The lock isn't damaged or anything though.

What I meant to say was that the lock is in the non locked position, if ya get me.

Redisle Registered User
#4

have you tried putting the card in say something else like a camera and seeing if you get the same error? it might be something to do with the card reader/pc

GrumPy Registered User
#5

Bollix to it anyway, I tried another card I had lying around, and got the same error.

The card reader is fecked.

Thanks for the tips anyway guys.

#6

IIRC it's like the write protect on a floppy drive in that it's mechanical not electronic

try the slider on the card both ways so it pushes against the toggle inside the reader

a linux boot CD is one way to check if its a hardware or software problem, unless the vendor has a bootable cd than can check sd cards, if it turns out that is a software problem then you would have to remove and reinstall the sd reader in device manager

if it's an external reader they are quite cheap so easy enough to replace
if it's built in then have a word with the vendor

Want to share your thoughts?

Login here to discuss!